Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: My Compool cp3600 went dead

  1. Back To Top    #1

    My Compool cp3600 went dead

    I have a compool cp3600 that had the inside display as well as the outside control panel go dead. I had an electrian check the connections as well as the power converters and all is well there. A technician from Leslie's Pools came out and told me the circuit board was bad, but after buying and installing a new one I had the same problem.

    There is a light that is illuminated on the back of the board that reads, "comport cable problem LD19" but I can't find out what this means. Does anyone know how to fix this problem, short of replaceing the cable from the control panel inside the house to the outside control panel?

    Thanks so much!

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: My Compool cp3600 went dead

    I don't know enough about the units now but I'd unplug the cable and see what it does.

    I see that Pentair offers a test cable so you might call them and ask what it means and see what the test cable costs.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Re: My Compool cp3600 went dead

    Russ, the identical problem just happened to my unit. Did you fix yours now and how?

  4. Back To Top    #4

    Re: My Compool cp3600 went dead

    cp3600 goes dead, or no response and faint bussing can be heard from control box. this happened to me. opened control panel found red led lit showing communication error. disconnected inside remote wire from pc board. manual control was restored. found that cable from inside remote to control panel shorted. replaced cable, now all back to normal.

  5. Back To Top    #5

    In the Industry
    Pool Clown's Avatar
    Join Date
    Sep 2008
    Location
    Silicon Valley, CA
    Posts
    1,637

    Re: My Compool cp3600 went dead

    Quote Originally Posted by toymaster53
    cp3600 goes dead, or no response and faint bussing can be heard from control box. this happened to me. opened control panel found red led lit showing communication error. disconnected inside remote wire from pc board. manual control was restored. found that cable from inside remote to control panel shorted. replaced cable, now all back to normal.
    That is everyone's problem. Typical problem: comm cable has been chewed/bitten/eaten.
    Factory Warranty Station for:
    Jandy/Zodiac, Pentair, Sta-Rite, Raypak, Polaris,
    and Paramount pool cleaning systems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •