Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Hayward SWG says low salt, wrong?

  1. Back To Top    #1

    Hayward SWG says low salt, wrong?

    Hello-

    My brother has a hayward turbocell with the goldline controller box. It was installed before he bought the house and seemed to work slightly from time to time (cell was shot).

    He put in a new cell yesterday (T-cell-15), but the controller screen displays "2500" and the low salt light flashes (says flashing indicates that cell is operating at reduced levels, due to the low salt condition).

    The old cell AND the new cell installed both have the computer screen showing 2500. However, the LPS tested his water and said he has 3800 ppm salt.

    Any idea why the pool store says he has plenty of salt, but the system thinks otherwise? We thought maybe the old cell was giving bad readings - - but the new cell is still showing the same thing.

    Thanks for your help!

    dmdrums

  2. Back To Top    #2

    Re: Hayward SWG says low salt, wrong?

    I have the same unit "Aqua-Rite" for about ~6.5yrs I think. At ~6yrs I had same issue, and then it gave "inspect cell". I ended up replacing both the cell and the flow switch.
    First try holding down the small black button for 3-5 seconds on the controller (next to the display).
    35,000 Gallon Gunite Pool/Spa
    Jandy DEL60 DE Filter
    Jandy AquaPure SWG
    2 Pool Skimmer / 1 Spa Skimmer
    Polaris 280

  3. Back To Top    #3

    Re: Hayward SWG says low salt, wrong?

    dalman-

    I was able to clear the "inspect cell" message by holding down the "diag" button for a few seconds. I'm just confused why the controller keeps saying 2500 and indicating low salt. I had the pool store test salt level AGAIN today and it is still 3800.

    Does it take a while after replacing a cell before this number is updated on the controller?

    Have a great night,

    dmdrums

  4. Back To Top    #4

    Re: Hayward SWG says low salt, wrong?

    it should not take long to display the reading;
    I would turn/ flip the main switch off on the controller Auto/Super C/ Off, if possible cut the power to controller.
    ( I have a switch box that turns off power to timer and controller) . leave off for a few minutes and turn power to box back on, then flip controller main switch up to Auto.

    I have to do this sometimes when adding salt, and forget to flip the main controller switch down to OFF position. It
    seems to get stuck (in this case it was stuck with hight salt).

    I hope this helps. I would not know what to check after that.
    35,000 Gallon Gunite Pool/Spa
    Jandy DEL60 DE Filter
    Jandy AquaPure SWG
    2 Pool Skimmer / 1 Spa Skimmer
    Polaris 280

  5. Back To Top    #5

    Join Date
    Dec 2009
    Location
    Palm Springs, CA
    Posts
    24

    Re: Hayward SWG says low salt, wrong?

    I also find that cleaning the cell will return the correct salt level readings.
    18k gallon in ground plaster with attached spa
    Pentair CCP 320 cartridge filter
    Goldline Aqua Rite SWG
    IntelliFlo VS pump
    Teledyne Laars ESC heater
    Hayward Pool Vac Ultra cleaner w/ skimmer Vac Plate and inline leaf basket
    Palm Springs, CA

  6. Back To Top    #6

    Re: Hayward SWG says low salt, wrong?

    Just wanted everyone to know it has fixed itself.

    Took a day or so and then the controller changed from 2500 to 3800.

    The reading on the screen is the same as the pool store!

    Perfect!

    Thanks,

    dmdrums

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •