Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Help needed with Autopilot.

  1. Back To Top    #1

    Help needed with Autopilot.

    My SC-60 cell is seven years old; The message said low amps, check cell. I first replaced salt; when that didn't solve the problem, I called my pool company who first replaced the cell; the message continued. They then came back, fixed wiring and replaced power mount; they took out the new cell, and it works. They have now said that the cell will probably go next spring, and we should consider buying a whole new unit which will be under warranty for two years instead of just replacing the cell next spring. They say that there can be problems if you put in a new cell. What do you recommend. Obviously the cost of the new unit is expensive (2300) compared with just putting in a new cell (1300 approx).
    Anne Kaelber
    Our Pool: 24,570 gallons, sand filter, IG plaster, 1 SHP Pentair Super Flo pump -- my blog -- Home of the SAWS+ Character Sheets!

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: Help needed with Autopilot.

    If I understand correctly they reinstalled the old cell after repairing the unit and it's working? If that's the case I'd just replace the cell whenever it goes out and not replace the unit. Since they replaced the power unit it's basically a new unit now.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts