Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Confused or Maybe not

  1. Back To Top    #1
    mvk111's Avatar
    Join Date
    May 2011
    Location
    Tampa, FLorida
    Posts
    62

    Confused or Maybe not

    Was hoping to get feedback on a filter / pump question. The builder just fired up the pool yesterday. I have a 53' Sta-rite Dura glas DE Filter. He put some DE and fired it up with my 1 hp sta-rite pump. The pressure read 18 psi right out of the gate, now from what I read it probably will run high real quick from all the construction debris and new plaster. When we turned the pump to the low speed the pressure dropped to at or just below 1 psi. I am still getting excellent flow out of the two returns on low speed. So my concern was is this right that on low speed the psi is that low in the filter. Should i be concerned at all or since I am getting flow out of the returns this indicates everything is working and my extra large filter is just doing a great job and is not overworked.

    Your comments will be very welcomed !! Thanks all !!
    15x30 free form (10,500 gal) SWG
    Gunite, Game depth 3.5-5-4 ft, 1 hp Sta-Rite Super Max 2 speed pump, 53' Sta-Rite system 3 DE filter
    Pentair Intellibrite LED
    Pentair 125k BTU ultra temp heat pump,
    Screen Enclosure
    TF-100 Test Kit

  2. Back To Top    #2
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,198

    Re: Confused or Maybe not

    Yes, pressure is very low when running on low speed. Mine drops to about 1 psi on low speed vs. about 10 on high speed. As long as the return flow is strong everything is good. As the pressure rises return flow will weaken.
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  3. Back To Top    #3
    mvk111's Avatar
    Join Date
    May 2011
    Location
    Tampa, FLorida
    Posts
    62

    Re: Confused or Maybe not

    Quote Originally Posted by zea3
    Yes, pressure is very low when running on low speed. Mine drops to about 1 psi on low speed vs. about 10 on high speed. As long as the return flow is strong everything is good. As the pressure rises return flow will weaken.
    Thanks zea3, it seemed to make sense but i was not expecting that low. Guess that is pretty decent for the filter in regards to time between cleaning and wear and tear.

    thanks again
    15x30 free form (10,500 gal) SWG
    Gunite, Game depth 3.5-5-4 ft, 1 hp Sta-Rite Super Max 2 speed pump, 53' Sta-Rite system 3 DE filter
    Pentair Intellibrite LED
    Pentair 125k BTU ultra temp heat pump,
    Screen Enclosure
    TF-100 Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •