Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 9 of 9

Thread: Can't get DE filter to prime after cleaning it

  1. Back To Top    #1

    Can't get DE filter to prime after cleaning it

    Hi! I am very new to taking care of a pool, so please forgive me if I sound like I don't know what I am doing....because I don't.

    I was in the hospital and when I got home my pool is completely green. I vacuumed to waste and then lost suction. I cleaned out the filter basket and then could not get it to re-prime. I then cleaned the DE filter (it was filthy....covered in algae and DE). I still can not get the pump to re-prime. When, the filter is off tons of air is coming out. When I turn the filter on, it takes a while and then a slow stream of water comes out. Also the skimmer basket does not stay full of water. It stays about 1/2-2/3 full but there do not appear to be any leaks around it.

    What position should the pool returns be in?

    What about the skimmers? I read that they should be closed when trying to re-prime.

    What about the main drain?

    Do you have any suggestions of other things that I should check for?



    Thank you!
    Steve-Liteguy

    13K Pebble-tech Pool, ECO pump, IntelliChlor SWG, DE

  2. Back To Top    #2
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,200

    Re: Can't get DE filter to prime after cleaning it

    Hi, welcome to TFP! Check that the skimmer basket in the pool skimmer is empty. Is the water level in the pool at least 1/2 way up the skimmer opening? If the water level is low the pump may not prime very well. Remove the lid from the pump strainer pot. Use a cup and fill the pot with water, then put the lid back on. Also, open the air bleeder on top of the DE filter before turning the pump on. Allow the filter to fill with water, then close the bleeder when a stream of water shoots out. If this does not help, post a couple of pictures of the problem and we'll see if we can figure out what is wrong.
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  3. Back To Top    #3

    Re: Can't get DE filter to prime after cleaning it

    Thank you so much for your help.

    I will go check the simmer baskets again. I did the other day when I was working on this but it was before I cleaned the DE filter.

    The water is high actually. I want to drain it before we get hit with this hurricane. It is draining very slow though. Does that sound like maybe something is clogged somewhere? How can I check for that?

    I have filled the pot with water and it then drains down to about 2/3-1/2 full....yet it not leaking at least what I can see.

    I am going to go do what you suggested now.
    Steve-Liteguy

    13K Pebble-tech Pool, ECO pump, IntelliChlor SWG, DE

  4. Back To Top    #4

    Re: Can't get DE filter to prime after cleaning it

    Ok, the skimmer baskets were all clear. The air was all out before I turned the filter back on and now more air is coming out of the filter. I have a small steady stream of water dribbling out but nothing like it is normally shooting out. I can see the air in the pump basket.

    Also the hot tub return and pool return are shooting out bubbles.

    Thanks again
    Steve-Liteguy

    13K Pebble-tech Pool, ECO pump, IntelliChlor SWG, DE

  5. Back To Top    #5

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,084

    Re: Can't get DE filter to prime after cleaning it

    Are you saying you can look into the pump basket lid and see some water tricking into it from the pool when the pump is running?
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  6. Back To Top    #6

    Re: Can't get DE filter to prime after cleaning it

    No sorry...I mean that I can see that the pump basket is not full and there is a lot of air in it. Usually, you can see that the water is at the top and there are just some bubbles.
    Steve-Liteguy

    13K Pebble-tech Pool, ECO pump, IntelliChlor SWG, DE

  7. Back To Top    #7

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,084

    Re: Can't get DE filter to prime after cleaning it

    Have you had to prime the system before? Did it do okay then? Can you tell me roughly (in feet) how high above the pool water level your pump is?
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  8. Back To Top    #8

    Re: Can't get DE filter to prime after cleaning it

    I'd say it's probably only a foot higher than the pool water. My pool is an inground pool and the pump is about 20 feet from the pool on the ground.

    I have cleaned out the basket before but this never happened.

    I almost had it today and then it basically just stopped gurgling at all. I shut it off and had to come inside due to the hurricane.
    Steve-Liteguy

    13K Pebble-tech Pool, ECO pump, IntelliChlor SWG, DE

  9. Back To Top    #9

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,084

    Re: Can't get DE filter to prime after cleaning it

    It sounds like you have developed a suction side leak. Somewhere between the impeller and the skimmer, you are sucking air into the system and it won't prime. If you find that leak, the pump will prime and all will be well.

    The most common places to look are the pump basket lid and o-ring, pump drain plugs, and any union or joint or valve.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •