Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Hayward pool heater problem

  1. Back To Top    #1
    linda1's Avatar
    Join Date
    Mar 2010
    Western Pa.

    Hayward pool heater problem

    I have a 14 month old Hayward natural gas heater. It has been use lightly, maybe 5-6 hours total. It just started acting up. I can turn it on and it will be fine then later I will notice that it has a CE code. Sometimes the code goes away and all is fine. Sometimes from the code the display will just go blank. We turn the heater on each day, but mainly to see what the water temperature is. My husband took the cover off, didn't notice any loose cable connections, etc. and it worked fine for a day or two and then started the intermittent normal display, ce code or no display at all. Any ideas?
    30 ft. round Conquest agp, 19,800 gal; Pentair Easy Clean 1 hp DE EC60 filter system
    Hayward H250N gas heater; TF100 Test Kit
    2 Fafco 4x20 sunsaver solar bear solar panels
    Pool Rover Jr. ~ Zoomerang slide
    Majestic 8000 Above-Ground Pool Step

  2. Back To Top    #2

    Re: Hayward pool heater problem

    CE indicates a Communications Error between the ignition control board and the display board. First, try removing and then reconnecting power to the heater. Second, check the wiring to make sure that it is securely connected. If one and two don't work, you might have to replace the ignition control board and/or display board.

    Note: Only qualified service technicians should repair heaters. Heaters can be dangerous to work on and use if the repair person is not properly qualified.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts