Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: DE in pool still

  1. Back To Top    #1

    DE in pool still

    I have a Pentair FN60 DE filter and noticed DE on the bottom of pool and in my robot cleaner. I replaced the grids (they were pretty ugly) and after putting all back together and running about a week now I still get DE settled on bottom. Seems to be less but still coming out. I took it apart today and checked if grids in ok. They looked seated. Took apart and filled manifold with water to check for leaks and noticed one spot that is slowly dripping water. Would this be my culprit or could it be the o-ring on the return tube? It really doesn't seem like a very good seal at the top of the grid to the manifold to begin with. And what the heck is that plastic plate for on top of the grids? It doesn't seem to do anything at all. Maybe I'm missing something please help!!!!

  2. Back To Top    #2

    Join Date
    May 2007
    South Central NJ

    Re: DE in pool still

    If you didn't lube the O-Ring on the return tube, I would say that that is adding to the leak in the manifold.

    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts