Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Aquarite Flow Switch and Fuse Issues

  1. Back To Top    #1

    Aquarite Flow Switch and Fuse Issues

    I keep blowing fuses. Now I'm not sure I have the right fuse in there. What fuse do I use for Goldline Aquarite SWG?

    Also, my dog chewed the wire to the flow switch awhile back. I was able to splice it and all has been well until recently, when it shows "No Flow" and my water is green. Shocking now.

    The switch is installed correctly and looks OK (no pieces missing inside). When I twist the two wires that lead to the switch together, shouldn't that give me a green flow light? I want to see if it is something else before I replace the flow switch.

    Also, in case I do need to replace it, where can I get one cheap?

    Thank you!

  2. Back To Top    #2

    Join Date
    Mar 2011
    Hazelton, PA

    Re: Aquarite Flow Switch and Fuse Issues ... glx-flo-rp

    If it's working properly, you should have no LED lite

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: Aquarite Flow Switch and Fuse Issues

    Whe you twist the flow switch wires together the no flow light should go out.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  4. Back To Top    #4

    Re: Aquarite Flow Switch and Fuse Issues

    Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts