Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Pump becomes un-primed the second I attach vacuum hose

  1. Back To Top    #1

    Pump becomes un-primed the second I attach vacuum hose

    Hi everyone, Just "acquired" a pool (bought a foreclosure) and though I have some knowledge about chemicals and cleaning etc. this pool is driving me nuts because its GREEN.
    i am shocking the heck out of it and was trying to do some brushing and vacuuming but the second I attach the hose (yes, I primed it and yes I bought a new one),the pump FREAKS and starts sucking air. I have experienced this before long ago but the pump always seemed to "catch up".
    It is almost like the pump is sucking too hard? Does that make sense?
    Can anyone help me? I am at a loss due to the GREEN and due to my vacuum not working.
    Thanks!

  2. Back To Top    #2

    Re: Pump becomes un-primed the second I attach vacuum hose

    Soccrplyr, check your hose. Does one end swivel and the other end not? If so make sure the swivel end is the end you attach to the vac as that end of the hose is not airtite and must be underwater at all times.
    10,800 gallons Gunite/Plaster
    Hayward 244t 24" Sand Filter with Zeo
    1 1/2 HP Challenger
    Digital Pool Pilot DIG-220 SC-48
    Located in NOLA

  3. Back To Top    #3

    Re: Pump becomes un-primed the second I attach vacuum hose

    Hi Dalandlord, Swivel end is on vac and submerged entire time while I prime hose from return.
    When I go to plug the other end into the skimmer hole, the suction is SO powerful it just grabs the end and sucks it into place. I would think this would be a good thing (lots of vacuum power) but it is so powerful the hose practically collapses and then the pump starts to sputter and un-prime. And then it never catches up. So I have no suction and an un-primed pump.

  4. Back To Top    #4

    Re: Pump becomes un-primed the second I attach vacuum hose

    Did you check the hose for an obstruction or holes? The only thing I could think of that would collapse the hose would be for it to be almost totally blocked. How big is the hose?
    10,800 gallons Gunite/Plaster
    Hayward 244t 24" Sand Filter with Zeo
    1 1/2 HP Challenger
    Digital Pool Pilot DIG-220 SC-48
    Located in NOLA

  5. Back To Top    #5

    Re: Pump becomes un-primed the second I attach vacuum hose

    Its 25 ft long and literally BRAND new.

  6. Back To Top    #6
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    Location
    SW Indiana
    Posts
    9,089

    Re: Pump becomes un-primed the second I attach vacuum hose

    Does the pool have a main drain or another skimmer?

    It sounds like you need a vac plate that allows some flow from the pool into the skimmer, as the hose alone can't handle the flow required by the pump.

    Or get a smaller pump. What do you have?
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  7. Back To Top    #7

    Re: Pump becomes un-primed the second I attach vacuum hose

    Now that makes some sense.
    I have a brand new FNS 48' DE filter and a brand new 1.5 hp Pentair pump.
    So it's called a vac plate? I can't get a smaller pump Just got this one!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •