Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 20 of 20

Thread: Red Service Light comes on - Intex Krystalclear SWG

  1. #1
    Junior Member
    Join Date
    Aug 2011
    Posts
    16

    Red Service Light comes on - Intex Krystalclear SWG

    Hello, I'm new here and been lurking for a while. I hope someone here can give some suggestions to fix my latest pool problem. I have an Intex Krystalclear saltwater system that I've had about two months, got it second hand off CL. It's worked great until yesterday - when I noticed it's red service light was on and solid (not blinking). I turned the unit off at the back switch, turned it back on and it's green "working" light came on for a few minutes then went off (back to solid red service light). So, I thought I'd clean the electrolytic unit. Unfortunately I was only able to soak and clean the copper electrode (with vinegar) as I didn't have the end caps for the clear housing that the titanium pieces are in. The end caps are now on order. Anyway after cleaning the copper pieces, I put it back together, turned the pump on, waited a few minutes and then turned on the SWG. Again the green "working" light came on for a few minutes then went off... back to the red "service" light. Anyone have an idea of what's going on? BTW, I'm pretty handy and have no problem working on the unit with a little guidance. I really appreciate any help I can get on this. My little girl's been planning a back to school pool party coming up in about a week - my finger's are crossed.
    4,240 gal. vinyl lined, metal framed pool. SWG (Intex Krystal Clear). ZeoSand filtration.

  2. #2
    Mod Squad Brushpup's Avatar
    Join Date
    Jun 2011
    Location
    Midland, TX
    Posts
    4,523

    Re: Red Service Light comes on - Intex Krystalclear SWG

    Im sorry I cant help, but I would suggest you getting some chlorine bleach on hand and in the pool to keep your FC level up. Just mentioning incase you havent already. Welcome to TPF and there will be someone along to help soon Im sure.

  3. #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    20,994

    Re: Red Service Light comes on - Intex Krystalclear SWG

    Ditto on getting the bleach in there now.

    You'll probably fix your problem once you clean the cell. You don't need the caps to clean the cell some. You can pour the vinegar through the cell into a bucket. It'll dissolve any deposits. You could try that and see if it helps.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 1.5hp Dynamo pump. 24" Pentair Sand Dollar Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit
    You can stop SLAMing your pool when you pass the OCLT (You lose 1ppm or less FC overnight, & You have .5ppm CC's or less) & your water is clear.

  4. #4
    Junior Member
    Join Date
    Aug 2011
    Posts
    16

    Re: Red Service Light comes on - Intex Krystalclear SWG

    Bleach, household bleach? How much for a 5100 gal pool? BTW - I forgot to mention that for the almost two months I've had the pool up and SWG connected, I (embarrassingly) didn't check the water with any kind of strips or any other testing methods. I just simply relied on the intex unit's digital display which never gave any kind of negative codes before the red service light came on. It's not that I didn't mean to get some test strips, cyanuric acids, etc.. but I just haven't YET. I figured "the water's nice and clear so it can wait a little longer.". The thing is - I assumed that since the titanium plates are not dirty looking, then they don't need cleaning.. but I realize too this could be a mistake. Would that have messed something up?
    4,240 gal. vinyl lined, metal framed pool. SWG (Intex Krystal Clear). ZeoSand filtration.

  5. #5
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    20,994

    Re: Red Service Light comes on - Intex Krystalclear SWG

    If you haven't done any testing then we really don't ahve a clue what it might be. You really need a good test kit.

    You need to tell us what chems you've added to the pool. we need to know how much of each, especially CYA and salt.

    You can use the Pool Calculator to fugure out how much to add but you're going to need to know FC now and CYA.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 1.5hp Dynamo pump. 24" Pentair Sand Dollar Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit
    You can stop SLAMing your pool when you pass the OCLT (You lose 1ppm or less FC overnight, & You have .5ppm CC's or less) & your water is clear.

  6. #6
    Junior Member
    Join Date
    Aug 2011
    Posts
    16

    Re: Red Service Light comes on - Intex Krystalclear SWG

    Thanks Bama, I've added nothing but water and pool salt (three - 40lb bags / 5100 gal pool as per Intex's instruction PDF) when I built the pool. Water has stayed clear as a bell for 2 months and the Krystalclear digital read out has given NO negative codes. I know that the test kit and full chemical makeup of the water is important though, even if the water's clear - can you recommend a good and simple test kit for me. I'd rather order it on line rather than get from Leslie's (I HATE that place, lol). Thanks again!
    4,240 gal. vinyl lined, metal framed pool. SWG (Intex Krystal Clear). ZeoSand filtration.

  7. #7
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    20,994

    Re: Red Service Light comes on - Intex Krystalclear SWG

    Do you have a chlorine/pH test kit? If so then I'd order the TF-50 from tftestkits. There's a link in my sig for them. If you don't have any test kit I'd go ahead and get the TF-100. It'll last you at least this year and next, and maybe a third year. I'd be remiss if I didn't recommend the SpeedStir also. It's the handiest thing for running the tests, especially the CH test.

    I know that's a lot for a test kit but it's definitely worth it and it'll save you tons of heart ache. And you'll never have to visit the pool store again unless you want to.

    If you haven't added any CYA you need some. While we're trying to figure out what's wrong with your swcg, you can get a floater at Wally-World and keep the chlorine in there. It'll add a little CYA as it's adding the chlorine too.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 1.5hp Dynamo pump. 24" Pentair Sand Dollar Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit
    You can stop SLAMing your pool when you pass the OCLT (You lose 1ppm or less FC overnight, & You have .5ppm CC's or less) & your water is clear.

  8. #8
    Junior Member
    Join Date
    Aug 2011
    Posts
    16

    Re: Red Service Light comes on - Intex Krystalclear SWG

    Bama, I'll keep that info on the kits tucked away until the off-season when I can afford it... I'm affraid that any extra funds I have available is about to go on buying another Intex Krystalclear SWG . I just got back from Wally-world, picked up test strips and some CYU acid, will report back on my finds.

    Update - I cleaned the entire cell (titanium plates and copper unit) with "Distilled White Vinegar", the thing still only works for about three minutes before shutting off. So two questions: 1) Will "distilled" vinegar clean just as well as any other vinegar? and.. 2) Are there any conditions that the water could be in that would shut the chlorinator off ? [remember my water is clear, if not a little cloudy now].
    4,240 gal. vinyl lined, metal framed pool. SWG (Intex Krystal Clear). ZeoSand filtration.

  9. #9
    Junior Member
    Join Date
    Aug 2011
    Posts
    16

    Re: Red Service Light comes on - Intex Krystalclear SWG

    Update 2: Strips show what I thought... only "water hardness" is in spec. FC is at zero (I just added a big chlorine tab to the float). Ph was as zero, Alkalinity at zero, Cyu acid at zero (so I just added some). Still though to the root of this thread, no of this should 'cause as SWG shut down, should it?
    4,240 gal. vinyl lined, metal framed pool. SWG (Intex Krystal Clear). ZeoSand filtration.

  10. #10
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    20,994

    Re: Red Service Light comes on - Intex Krystalclear SWG

    Don't trust those strips. There's no way the pH is zero. Low maybe but not zero. Take a sample to the pool store and have them test it before you go adjusting anything seriously.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 1.5hp Dynamo pump. 24" Pentair Sand Dollar Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit
    You can stop SLAMing your pool when you pass the OCLT (You lose 1ppm or less FC overnight, & You have .5ppm CC's or less) & your water is clear.

  11. #11
    Junior Member
    Join Date
    Aug 2011
    Posts
    16

    Re: Red Service Light comes on - Intex Krystalclear SWG

    HTH has a 6 way test kit (very similar to the tftestkit) at wal-mart for around $19 - any reason to skip on that one?
    4,240 gal. vinyl lined, metal framed pool. SWG (Intex Krystal Clear). ZeoSand filtration.

  12. #12
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    20,994

    Re: Red Service Light comes on - Intex Krystalclear SWG

    That kit's a good interim kit. It's ok until you can get a good kit. it only has 2 CYA tests IIRC. The TF kits wind up being cheaper per test when you figure in the number of each test.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 1.5hp Dynamo pump. 24" Pentair Sand Dollar Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit
    You can stop SLAMing your pool when you pass the OCLT (You lose 1ppm or less FC overnight, & You have .5ppm CC's or less) & your water is clear.

  13. #13
    Junior Member
    Join Date
    May 2012
    Posts
    1

    Re: Red Service Light comes on - Intex Krystalclear SWG

    Did you ever figure out what made your light come on mine has been doing the same thing this year and i cant figure out what is wrong with it, we just bought it last summer and intex will not tell you anything

  14. #14
    Junior Member
    Join Date
    Jun 2012
    Posts
    2

    Re: Red Service Light comes on - Intex Krystalclear SWG

    My SERVICE light kept coming on and I took my system apart and cleaned everything with a toothbrush. I also switched to a larger wire extension cord. After those two things the system has been working fine. Knock on wood!!!

    58n65

  15. #15
    Junior Member
    Join Date
    Jun 2012
    Posts
    1

    Re: Red Service Light comes on - Intex Krystalclear SWG

    My RED SERVICE LIGHT came on. The issue was caused by corrosion on the circuit board. You will need a philips head screw driver and a small cutter to cut a tie wrap in order to inspect the board. Be sure to unplug the unit from all electric.

    Before I tried all of this, I did the vinegar cleaning as I do every year as maintenance. It didn't resolve the issue, but I would recommend trying it first.
    If your unit is still under warranty, contact the manufacturer before you void any warranty by doing any work to it yourself.

    Here is the step by step of what I did:

    I took loosened the four philips head screws and removed the cover of the electronics.
    I took several digital photos of the circuit board so that I could put it back together the way it belonged.
    I unplugged everything from the circuit board and removed the board completely from the unit. All that holds it in are 4 little plastic tabs that you squeeze together to release the board.
    I attempted to clean and re-solder the corroded connections myself, but I am not good at it and my soldering gun is in poor condition.
    I brought the circuit board to a nearby electronics place. They charged $25 minimum to do soldering. It was done in 5 minutes and it was worth $25.
    I re-installed the board in the reverse of which I removed it and then put the entire unit back together. When I turned it back on it worked perfectly.

    Some lady does a youtube video of it with virtually no audio, but it does display what I have described.
    15,360 gal/IG/Vinyl/Sand/Hayward Pump 1HP/SWG

  16. #16
    Junior Member
    Join Date
    Jun 2012
    Posts
    2

    Re: Red Service Light comes on - Intex Krystalclear SWG

    Yeah I'm in electronics so I can take the board out and resolder it, but until it messes up again I won't touch it. If it ain't broke don't fix it!!! This is my third system....returned the first two under warranty.

    Great forum with great advice on here!!!

    58n65

  17. #17
    Junior Member smilen1122's Avatar
    Join Date
    Jul 2012
    Posts
    1

    Re: Red Service Light comes on - Intex Krystalclear SWG

    So - its o.k. to put just regular bleach in a salt water pool? We have recently gotten alot of rain and my water is turning green. I'ev also had problems with the Red "Low Salt" light. I've cleaned the electrode and just ordered a new one. I'm wondering if I can put the bleach in until I can get the new electrode installed. Thanks - helpful info here

  18. #18
    Junior Member
    Join Date
    May 2013
    Posts
    2

    Re: Red Service Light comes on - Intex Krystalclear SWG

    My red service light kept coming on. I called Intex. What a joke,took 4 calls to get an answer to my problem.They finally sent me a new control system.Upon hooking it up and running it for 12 hours with the filter on a 24 hour cycle,it shorted out the cell,caught fire and melted the wire connector at the cell.THE GROUND FAULT NEVER TRIPPED. Glad no one was in the pool!!!!

    Now we are going in circles with the form readers when I call them again.So far have 3 more claim numbers,some say it's covered,others say it's not. I have owned it for 12 1/2 months.

    The company has no "service techs" that can answer your questions,

  19. #19
    Junior Member
    Join Date
    Jun 2013
    Posts
    1

    Re: Red Service Light comes on - Intex Krystalclear SWG

    I have the Intex CS8110 SWG and I had the 'red light' problem. I called them. They told me it was a Control module failure and they are sending me a replacement (still under warranty). I've been using this type system for 3 years now and I won't go back to any other method.

  20. #20
    Junior Member
    Join Date
    May 2013
    Posts
    2

    Re: Red Service Light comes on - Intex Krystalclear SWG

    They finally sent me the other part that burnt. In the mean time went and bought another system and noticed they changed the design of the control system and the tube.The new ones have a tapered tube,different fins inside of it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •