Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 10 of 10

Thread: Struggling with Suntouch and Intelliflo VF for Solar

  1. Back To Top    #1

    Join Date
    Jun 2011
    Location
    Santa Barbara, CA
    Posts
    30

    Struggling with Suntouch and Intelliflo VF for Solar

    I'm having some trouble configuring my Suntouch and Intelliflo VF to work together in my solar system. No matter what I do, I can't seem to get the flow to increase properly when the solar is activated. My goal is simple, I want the pump to run at low speed (15 GPM) for 1 turnover when the solar is off, and at high speed (40 GPM) when the solar is active. The suntouch is correctly sensing the temperature and switching the valve for solar, but the pump doesn't increase speed, it just stays at the low speed. No matter what settings I make in the circuit settings menu, the pump stays slow. Anyone with a similar setup have advice for me?
    31'x15' 19k gallon IG plaster/paint pool, 3 HP Intelliflo VF pump, 400 sq-ft DE Filter, 320 sq-ft Solar Panel, 400k BTU NG Heater (Unused)
    450 Gallon Marquis Epic Spa

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Struggling with Suntouch and Intelliflo VF for Solar

    First make sure your have the SunTouch setup to know that it is controlling an IntelliFlo pump. Then, on the Pumps menu pick a pump speed to use for solar (ie slot 2, 3, or 4), set the RPM to something appropriate for the solar system, and the circuit to solar.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Jun 2011
    Location
    Santa Barbara, CA
    Posts
    30

    Re: Struggling with Suntouch and Intelliflo VF for Solar

    That's pretty much the settings I've tried, although since it's a VF pump, I set GPM rather than RPM.
    31'x15' 19k gallon IG plaster/paint pool, 3 HP Intelliflo VF pump, 400 sq-ft DE Filter, 320 sq-ft Solar Panel, 400k BTU NG Heater (Unused)
    450 Gallon Marquis Epic Spa

  4. Back To Top    #4
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Struggling with Suntouch and Intelliflo VF for Solar

    The one other thing to keep in mind is that the speed for the circuit with the highest speed slot # that is currently active will be the one that gets used. Normally you put your higher speeds in higher slot numbers, so the highest speed wins. But if you have a higher slot set to a lower speed with an active circuit it could over-ride the solar speed.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  5. Back To Top    #5

    Join Date
    Jun 2011
    Location
    Santa Barbara, CA
    Posts
    30

    Re: Struggling with Suntouch and Intelliflo VF for Solar

    Nope, that's not it either. All of the circuits above Solar (in #2) are set to none.
    31'x15' 19k gallon IG plaster/paint pool, 3 HP Intelliflo VF pump, 400 sq-ft DE Filter, 320 sq-ft Solar Panel, 400k BTU NG Heater (Unused)
    450 Gallon Marquis Epic Spa

  6. Back To Top    #6
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Struggling with Suntouch and Intelliflo VF for Solar

    Is the SunTouch able to control the speed at all? That is, if you change the speed in slot 1, normal pump, does the speed change on the pump?
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  7. Back To Top    #7

    Join Date
    Jun 2011
    Location
    Santa Barbara, CA
    Posts
    30

    Re: Struggling with Suntouch and Intelliflo VF for Solar

    Yes, indirectly through the Pool Size, Turnovers and Schedule settings. For example, right now, I have it set to 17kgal, 1 turnover, and 9.5 hours of run time. The pump is running at 29GPM, which is correct for those settings. The flow setting in slot 1 (Pool/Spa) is set to 15GPM and appears to be ignored. Slot 2 (Solar/HT) is set to 40GPM.
    31'x15' 19k gallon IG plaster/paint pool, 3 HP Intelliflo VF pump, 400 sq-ft DE Filter, 320 sq-ft Solar Panel, 400k BTU NG Heater (Unused)
    450 Gallon Marquis Epic Spa

  8. Back To Top    #8

    Join Date
    May 2011
    Location
    Orange County, CA
    Posts
    696

    Re: Struggling with Suntouch and Intelliflo VF for Solar

    If I understand correctly, you want to have the pump run at 15GPM for one turnover, but the Suntouch calculates that you need 29GPM for one turnover in 9.5 hours when solar is not used. But, you want 40GPM if solar is used. So shouldn't your pool/spa setting (slot 1) be set to 29 GPM?
    38K in ground pool with attached spa. Current equipment: Easytouch 8 (521150) with IC-60 SWCG with web control by Autelis, 1x Pentair IntelliFlo 011018 pump (for filter), 1x Pentair 2HP WhisperFlo pump (for waterfall), 2X Pentair IntelliBrite 5G 12V lights, Pentair MiniMax400 NG Heater, Pentair SMBW2060 DE filter. Zodiac Barracuda MX8 cleaner on dedicated cleaner line. Lighting/home automation controlled by Insteon/ISY-99i.

  9. Back To Top    #9

    Join Date
    Jun 2011
    Location
    Santa Barbara, CA
    Posts
    30

    Re: Struggling with Suntouch and Intelliflo VF for Solar

    Quote Originally Posted by CraigMW
    If I understand correctly, you want to have the pump run at 15GPM for one turnover, but the Suntouch calculates that you need 29GPM for one turnover in 9.5 hours when solar is not used. But, you want 40GPM if solar is used. So shouldn't your pool/spa setting (slot 1) be set to 29 GPM?
    I don't really care about the low speed right now, as I know how to set that. The problem I'm trying to solve is the failure of the system to speed up to 40GPM when solar is used. Do you think setting the slot 1 speed to match the calculated speed will make the slot 2 (solar) speed work properly?
    31'x15' 19k gallon IG plaster/paint pool, 3 HP Intelliflo VF pump, 400 sq-ft DE Filter, 320 sq-ft Solar Panel, 400k BTU NG Heater (Unused)
    450 Gallon Marquis Epic Spa

  10. Back To Top    #10

    Join Date
    Jun 2011
    Location
    Santa Barbara, CA
    Posts
    30

    Re: Struggling with Suntouch and Intelliflo VF for Solar

    Just as a followup to this, I contacted Pentair, and they identified a bug in my board. After sending my board back to them for testing, they sent me a new board that worked properly.
    31'x15' 19k gallon IG plaster/paint pool, 3 HP Intelliflo VF pump, 400 sq-ft DE Filter, 320 sq-ft Solar Panel, 400k BTU NG Heater (Unused)
    450 Gallon Marquis Epic Spa

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •