Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Super II pump running very hot.

  1. Back To Top    #1

    Join Date
    May 2008
    Location
    Ridgewood NJ
    Posts
    16

    Super II pump running very hot.

    I have a 2hp super pump ii that i just noticed is running very hot, too hot to touch. The pump is about 11 years old and it is H rated and running. Today I cleaned the impeller which was only minimally dirty and changed the ceramic seals. I also tested the voltage to the pump and it is getting 118 x 2 as expected. The motor shaft turns freely. Should I be worried? What else can I try to lower the temp. What else could be a load on the motor, could the centrifigal clutch not be disengaging? I am not sure what it should like but the 'weights' are spinning on the back end of the pump when I just tested the voltage. The pressure in the DE filter is not high, 20, which is normally what I get after backflushing and cleaning which I just did.
    Thanks
    Len
    35,000 gallon IG pool. pebblefina sapphire galaxy finish
    2hp Hayward 2 speed pump, Hayward DE600 grid filter, Hayward Heater, Polaris booster and 280 cleaner
    Liquidator

  2. Back To Top    #2

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,078

    Re: Super II pump running very hot.

    Pool pumps run hot. Mine runs too hot to touch as well. Years ago, I was going to install a cooling fan......I never did and the pump continues to run as it always has.....too hot for my liking but, apparently, perfectly normal.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •