Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Kleen-a-tron

  1. Back To Top    #1


    This robot stopped climbing the walls. It will move around the bottom erratically. As I look at it, it seems as though it's not "sticking" to the wall. It attempts to go up but begins to float away from the wall, like there isn't enough water jet pressure to keep it stuck to the wall.

    Sometimes as it's moving along the bottom, the handle will appear to "pop up" and it will stop for a second and then keep going; sometimes it'll change directions. I tried putting a float on the handle and did not see a difference.

    Anybody seen anything like that?

    Belts were replaced.

    I do have a ton of kinks in the power wire - but I don't think that's keeping it from climbing.

    20x40 Kafko pool, Pentaire SD80 filter, Intelliflow pump, 8 foot deep end, Autopilot

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: Kleen-a-tron

    I don't know the Kleen-a-tron, but my Dolphin has that problem when the debris bag is either full or has gotten extra dirty over several uses. At that point I wash the bag out and run it through the laundry and it is fine again.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Oct 2007
    Parkland, FL

    Re: Kleen-a-tron

    i agree, bag is probably dirty. try to throw it threw the washing machine, or buy a new one. if thats not it, then most likely the pump motor is going.
    12000 gal diamond brite pool with 400 gal spillover spa, 1 1/2 HP pump and Hayward 1100 cartridge filter, Hayward Heatpump.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts