Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 11 of 11

Thread: Sta-Rite Heater Problem

  1. #1
    Junior Member
    Join Date
    Jun 2011
    Posts
    5

    Sta-Rite Heater Problem

    I bought my house 2.5 years ago and originally my sta-rite heater had the "service heater" light on. I never did anything about it. Now 6 months ago it would randomly turn on and off while the pump was running. I still did nothing about it. Now its not working at all and all of the lights on the controls are lit. The lights on both the front side and the diagnostic lights on the bottom side of the membrane. I am curious if my issue is mainly the membrane pad. I realized after it broke down that it has been missing a plastic covering over the temperature gauge. I assume that this has allowed it to get water inside. Can anyone help me out? Thanks.
    Seamus
    Slainte
    20,000 gal IG Gunite Pool - 1/2hp Hayward North-star Pump SP4005
    Hayward Swimclear Filter C4030 Sta-Rite SR400NA Max-E-Therm Heater, 400-BTU
    Jandy APURE35 AquaPure 35K Gallon EI Saltwater Chlorinator 120/240V - Nitro Wall Climber/scrubber

  2. #2
    Senior Member
    Join Date
    Mar 2007
    Location
    Coastalish 'down easter'
    Posts
    4,162

    Re: Sta-Rite Heater Problem

    Welcome to TFP!!

    First question is how is you gas? (if it's a natural gas heater, disregard - if it's propane, how's the tank level?)

    Can you post a pic of both sides (top and bottom) of the control pad when the lights are lit?

    I've played with more Sta-Rite heaters than I care to remember
    Luv& Luk
    -Ted

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

  3. #3
    Junior Member
    Join Date
    Jun 2011
    Posts
    5

    Re: Sta-Rite Heater Problem

    Attached are both the pictures showing all of all the lights lit up. Thanks. Oh and it is natural gas.
    Attached Images Attached Images
    Seamus
    Slainte
    20,000 gal IG Gunite Pool - 1/2hp Hayward North-star Pump SP4005
    Hayward Swimclear Filter C4030 Sta-Rite SR400NA Max-E-Therm Heater, 400-BTU
    Jandy APURE35 AquaPure 35K Gallon EI Saltwater Chlorinator 120/240V - Nitro Wall Climber/scrubber

  4. #4
    Senior Member In the Industry

    Join Date
    Mar 2011
    Posts
    277

    Re: Sta-Rite Heater Problem

    Turn the power off to the heater, for 30 seconds and turn it back on. If all of the LEDs remain illuminated you will need a new control board.
    20X40 30,000 gallon gunite pool

  5. #5
    Junior Member
    Join Date
    Jun 2011
    Posts
    5

    Re: Sta-Rite Heater Problem

    Ok no need in taking a picture...I turned off the power and turned back on and now there are no lights lit on the top or bottom. Does that still mean I need a new control board?
    Seamus
    Slainte
    20,000 gal IG Gunite Pool - 1/2hp Hayward North-star Pump SP4005
    Hayward Swimclear Filter C4030 Sta-Rite SR400NA Max-E-Therm Heater, 400-BTU
    Jandy APURE35 AquaPure 35K Gallon EI Saltwater Chlorinator 120/240V - Nitro Wall Climber/scrubber

  6. #6
    Junior Member
    Join Date
    Jun 2011
    Posts
    5

    Re: Sta-Rite Heater Problem

    Bump
    Seamus
    Slainte
    20,000 gal IG Gunite Pool - 1/2hp Hayward North-star Pump SP4005
    Hayward Swimclear Filter C4030 Sta-Rite SR400NA Max-E-Therm Heater, 400-BTU
    Jandy APURE35 AquaPure 35K Gallon EI Saltwater Chlorinator 120/240V - Nitro Wall Climber/scrubber

  7. #7
    Senior Member
    Join Date
    Mar 2007
    Location
    Coastalish 'down easter'
    Posts
    4,162

    Re: Sta-Rite Heater Problem

    Sorry for the delay

    If 'resetting' it, as per racket, worked and the heater is now running, you're all set
    Luv& Luk
    -Ted

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

  8. #8
    Junior Member
    Join Date
    Jun 2011
    Posts
    5

    Re: Sta-Rite Heater Problem

    No sorry it is still not running.
    Seamus
    Slainte
    20,000 gal IG Gunite Pool - 1/2hp Hayward North-star Pump SP4005
    Hayward Swimclear Filter C4030 Sta-Rite SR400NA Max-E-Therm Heater, 400-BTU
    Jandy APURE35 AquaPure 35K Gallon EI Saltwater Chlorinator 120/240V - Nitro Wall Climber/scrubber

  9. #9
    Junior Member
    Join Date
    May 2011
    Posts
    7

    Re: Sta-Rite Heater Problem

    I have Sta-Rite Heater (Natural Gas SR400NA) and it is not working. When the pump is not running the "service system" light is on (red) when the pump is running the "service heater" light is on (red). Where do I go from here? What do I open to get to the contoller board that has the LEDs? And thoughts are of value.

    thanks
    36,000 gallon in-ground vinyl liner, Pentair Triton II Fiberglass Sand Filter TR-140, Pentair Triton wisperFlo 3 HP Pump, located in the pacific northwest.

  10. #10
    Member In the Industry

    Join Date
    May 2011
    Posts
    38

    Re: Sta-Rite Heater Problem

    gonna be a fast post,

    when the pump is off you are getting service system bc the water pressure switch is dropping out (tells me its wired wrong) Service heater means we need to know what lights are on behind the board.

  11. #11
    Senior Member In the Industry
    Pool Clown's Avatar
    Join Date
    Sep 2008
    Location
    Silicon Valley, CA
    Posts
    801

    Re: Sta-Rite Heater Problem

    I know this is an old post.

    To original poster:

    Is this a test??

    Who else besides me sees a problem with the condition of that touch pad? There is a probability that one or more of the push buttons are closed(shorted) preventing the heater from doing anything.

    Also the condition of that membrane is not keeping any (rain)water off the PCB! So you may need a board AND a touch pad.


    Given the date, you have probably already fixed this problem.
    Factory Warranty Station for:
    Jandy, Pentair, Sta-Rite, Raypak, Polaris,
    and Paramount pool cleaning systems.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •