Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 9 of 9

Thread: low current readings on Aqua rite t-3 cell

  1. Back To Top    #1

    low current readings on Aqua rite t-3 cell

    I recentlu installed an Aqua rite T-3 SWG system and m very happy with it. It stopped chlorinating aan I went through the readings. All seem OK accept the voltage is 25.5 and the current is low at 2.73. I did let the system run for awhile before I took the readings. Salt is 3100, temp is 82 f, chlorinating light is on,and dial is set @ 100% and reading is showing 100%. Could a cell cleaning raise the current? could I have reversed the power wires. I have had the system running for a month And, it was chlorinating. I tested daily and it was staying at 2 ppm.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,337

    Re: low current readings on Aqua rite t-3 cell

    Cleaning it wouldn't hurt.
    What size pool do you have?
    Can you post a set of test results and how you got them?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3
    Aquatica's Avatar
    Join Date
    Jun 2010
    Location
    Nassau, Bahamas
    Posts
    514

    Re: low current readings on Aqua rite t-3 cell

    sounds like it is chlorinating.

    however I have a 14,000 gal pool and we are running the pump 24/7 and have the T3 cell at 100% and it's still having problems keeping up with chlorinating the pool. The high UV index, swimmers and the size of the pool are taking its toll on the little T3 cell.

    Had a 8,000 gal pool have problems keeping up with an older T3 cell so we switch to a T15 and no problems now.

    Yes what size is your pool?
    What is your CYA?
    How long are you running the pump?

    btw ..its normal for current of a T3 cell to be that low.

  4. Back To Top    #4

    Join Date
    Oct 2010
    Location
    Georgia
    Posts
    317

    Re: low current readings on Aqua rite t-3 cell

    The 4.50 to 7.80 amps is for T-cell-15.
    The t-cell-3 normally draws from 1.5 to 3 amps.

    Proper water balance is important for optimum performance of all salt systems.
    Goldline recommends a CYA level of 60 to 80 ppm for these units.

    Post a complete set of water test results and some of the good folks on this forum can help.
    poolschoolgrad

    20x40 free-form IG vinyl, 1hp Hayward superpump, Hayward pro grid DE filter, Raypak heatpump, Goldline Aquarite SWCG, Polaris 280 with booster, and tested using a Taylor K2006.

  5. Back To Top    #5

    Re: low current readings on Aqua rite t-3 cell

    Hi All, I cleaned the cell today by soaking it in a 3 to 1 water/ muratic acid. I soaked it for an hour and rinsed it out. I washed my filter and reinstalled both. I checked the pool water with a test strip and it shows 1.5 ppm chlorine,200 total hardness, 8.0 pH, 120 total Alkand and 70 CYA. I've been working with a local pool store at getting the chems dialed and she's got me where she wants. The pH is a bit high, so I'll work on that. When I first installed the system, I had to turn it down because it was making too much chlorine. Now I've got it maxed out and it's barely showing up on the test strips.

  6. Back To Top    #6

    Join Date
    Oct 2010
    Location
    Georgia
    Posts
    317

    Re: low current readings on Aqua rite t-3 cell

    What size pool?
    How many hours per day are you running the system?

    You have inadvertently lowered the output % too much and allowed algae to start to grow.
    The PH and total alkalinity are high.
    pool-school/water_balance_saltwater_generator

    You will need to shock your pool to destroy this algae.
    pool-school/shocking_your_pool

    With a CYA of 70 a chlorine concentration of 2 is not sufficient.
    After the shock process, you need to keep the Aquarite set to produce enough chlorine to maintain the pool at 5 ppm.
    pool-school/chlorine_cya_chart_shock

    PSG
    poolschoolgrad

    20x40 free-form IG vinyl, 1hp Hayward superpump, Hayward pro grid DE filter, Raypak heatpump, Goldline Aquarite SWCG, Polaris 280 with booster, and tested using a Taylor K2006.

  7. Back To Top    #7

    Re: low current readings on Aqua rite t-3 cell

    Hi all, my pool is close to 8000 gallons. I don't have algea yet and I think I'm goin to add some liquid chlorine to avoid it. Can I use muratic acid in a vinyl pool? Changing to a stronger cell sound like a good idea. Thanx for the specs on the t3 cell. I have not seen those specs anywhere on my lit or on the net

  8. Back To Top    #8
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: low current readings on Aqua rite t-3 cell

    Yes, you can use muriatic acid in a vinyl pool. Add it by pouring slowly in front of a return jet while the pump is running.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  9. Back To Top    #9

    Re: low current readings on Aqua rite t-3 cell

    Thanks for the info about the acid. Do you know if I can exchange my T3 cell for a T15 at an Aqua pure dealer?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •