Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: New Pool...Just hooked up SWG...and it leaks. HELP!

  1. Back To Top    #1

    New Pool...Just hooked up SWG...and it leaks. HELP!

    Hello!

    I am so thankful to have found this forum!

    A few weeks ago, we purchased an Intex Metal 15' x 48". Finally were able to set it up and fill it this past week. Have had the filter pump hooked-up and running since day 1 (not 24 hr...but working).

    We have done NO testing yet (whoops) and have only taken one dip. We're hoping to have a "pool party" (just a few friends) on Sunday. My wife and I went out tonight to set up the SWG to the filter pump...and the thing leaks! Eeks!

    First...how do we fix the leaks? The leaks are located at both ends of the connection from the filter pump to the SWG?





    Also...beside fixing the leaks. Is there anything we can do so that we can still use the pool by Sunday?

    Thank you!

    Daniel
    Intex 15' x 48" with SWG
    FC 5
    pH 8
    TA 80
    C .1

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,345

    Re: New Pool...Just hooked up SWG...and it leaks. HELP!

    There should be o-rings in the fittings. You cna lube them with pool lube and see if they'll seal.

    Test and balance the water and there's no reason you can't swim.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Re: New Pool...Just hooked up SWG...and it leaks. HELP!

    Dave,

    Thank you for taking the time to answer my question.

    There are the O-rings on teh top pictured "connection". However, there is also some sort of plastic "lip" at the SWG connection site that seems to be holding things up.

    As far as the bottom picture...see how the filter pump is curved at the bottom? It seems to be pushing the connection hose off...and there are NO threads to secure the connection there.

    Thank you!

    Daniel
    Intex 15' x 48" with SWG
    FC 5
    pH 8
    TA 80
    C .1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •