Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: aqua rite t-cell 9 reading hot after cleaning

  1. Back To Top    #1

    aqua rite t-cell 9 reading hot after cleaning

    Well my salt reading was not accurate so I cleaned my cell buy the book with muriatic acid. After cleaning when I turned on the cell it gave me cold reading , then hot. Now stays reading hot. Even when I turn to super chlorinate to bypass temp reading the check salt light and the inspect cell light comes on solid. The generating light starts flashing halting generation. I tried to check instant salinity but reads 0, but water has salty taste. Did I do something wrong when cleaning cell cause everything worked before cleaning except salt reading. Any help would be greatly appreciated.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: aqua rite t-cell 9 reading hot after cleaning

    How long have you had the cell?
    I would suggest checking and cleaning the connections. A bad connection might cause what you're seeing.

    What you experienced might be coincedence.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3
    Aquatica's Avatar
    Join Date
    Jun 2010
    Nassau, Bahamas

    Re: aqua rite t-cell 9 reading hot after cleaning

    Hot is never a good reading. all the hot readings I've had meant cell was fried.

  4. Back To Top    #4

    Re: aqua rite t-cell 9 reading hot after cleaning

    Cell was put in last april new pool. Is the temp connection in cell or the thing with the wire right past the cell? Only year and a couple months on cell do they just go bad sometimes? Thanks for the info great forum. New to the whole pool thing all ready learned alot from this forum.

  5. Back To Top    #5
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: aqua rite t-cell 9 reading hot after cleaning

    Is the cell right after the pool heater and is the pool heater running? Also press the diagnostic button once and tell us what number it displays.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  6. Back To Top    #6

    Re: aqua rite t-cell 9 reading hot after cleaning

    Just got off the phone with hayward co. They said probably temp sensor in cell getting a new one under waranty . I still would like to know what happened though, is it possible to fry temp sensor with acid? Like I said before no problems until I cleaned it except for inaccurate salt reading. Just want to avoid this again in future if possible. I did try rebooting system this morning and got it to give me instant sality of 4000 but after 30 seconds read hot again and continued same trouble. Thanks for the replies and help. God bless

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts