Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 14 of 14

Thread: High Salt light on the Aqua Rite system remains on

  1. Back To Top    #1

    High Salt light on the Aqua Rite system remains on

    Good question and problem. I am here because I'm having same issue. System been working fine. Couple days ago, the High Salt light staying on. Tested water, no chlorine. Went to supply store, bought all necessary/recommended stuff, put in pool. Water looks and tested good now, but the High Salt light on the Aqua Rite system remains on. Can't make it go off.

    Help?

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: High Salt light on the Aqua Rite system remains on

    A high salt light almost always means the salt level actually is too high. Unless you have some specific reason to be confident that the salt level isn't too high, you should replace water to bring the salt level down.

    It would also help if you post a complete set of water test results.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Re: High Salt light on the Aqua Rite system remains on

    The salt was tested at 3700, which probably meant that High Salt light should have been on. We put in the chemicals recommended by the supply store, and also drained some water out of the pool and refilled the water to proper levels. Maybe we didn't drain enough water? Maybe we did, but it takes some amount of time for the Aqua Rite system to correct itself for the new salt level ? If so, how long does it take for the Aqua Rite system to correct it's reading and turn the light off?

  4. Back To Top    #4
    JesseJames's Avatar
    Join Date
    Sep 2009
    Location
    Florida
    Posts
    64

    Re: High Salt light on the Aqua Rite system remains on

    I have had the high salt problem too. My test were saying one thing and the SWG another. I drained water three different times and finally the blinking lights went away. So, I really did have too much salt and you probably do as well.

    You might try shutting the system down and restarting/resetting to see if that helps.
    13K Gal., Plaster, SWG, Intellichlor IC 20, Sta-Rite 1 HP Pump, Sta-Rite PLM 300 Filter, Pentair LED, Solar, Screened Enclosure, Great White, TF-100

  5. Back To Top    #5
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: High Salt light on the Aqua Rite system remains on

    The salt display on an Aqua Rite is an average of the readings over the last 24 hours, so it can take up to 24 hours for it to display a new number after water replacement.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  6. Back To Top    #6

    Re: High Salt light on the Aqua Rite system remains on

    Ok, good to know, JesseJames, thanks.

    Just for clarity, on my panel there are no blinking lights, only a solid red light, High Salt.

    I have shut the system down and restarted. Also, turned the power completely off to the system, just for grins and to get a complete 'reboot'.

  7. Back To Top    #7

    Re: High Salt light on the Aqua Rite system remains on

    Thanks, JasonLion. Should I be running the system now in the normal on position while it's getting the 24 hour average, or should I turn the system off a while (24 hours)?

  8. Back To Top    #8
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: High Salt light on the Aqua Rite system remains on

    Go ahead and leave it on.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  9. Back To Top    #9

    Re: High Salt light on the Aqua Rite system remains on

    The High Salt light is still on. I drained and added some water. May have to do it again. But, three questions, please:
    1. The High Salt light started all this, and low chlorine in the pool, and I hadn't added any salt lately. So, how did the pool get too high a level of salt?
    2. Can't rule out the possibility of a bad panel. Is there a way to troubleshoot and determine if the panel is bad?
    3. How can I determine if the cell is bad?

    Thanks!

  10. Back To Top    #10

    Re: High Salt light on the Aqua Rite system remains on

    After having this same problem and was unable to correct had a pool guy come out to check the panel. Was told that one setting on the panel should read T19 and it had been set at T3. Not sure how this happened but it has happened again. Does anyone know how to reset the T level reading?

  11. Back To Top    #11

    Join Date
    Oct 2010
    Location
    Georgia
    Posts
    317

    Re: High Salt light on the Aqua Rite system remains on

    For units with software version 1.5 and higher

    To Set Turbo Cell Type

    Before operation, the Aqua Rite must be configured for the chlorinator cell that will be
    used. Refer to the following information and steps below to set the Turbo cell type.

    "t-3" = T-CELL-3, GLX-CELL-3-W
    "t-5" = GLX-CELL-5, GLX-CELL-5-W
    "t-9 = T-CELL-9, GLX-CELL-9-W
    "t-15" = T-CELL-15, GLX-CELL-15-W

    1. Slide the Main Switch to the "Auto" position.
    2. Push the Diagnostic button repeatedly until "t-xx" appears on the display ("t-15" is
    the factory default). If the desired cell type is displayed skip to step 4.
    3. To change to a different cell type, slide the Main Switch from "Auto" to "Super
    Chlorinate" and back to "Auto". Repeat this process until the desired cell type is
    displayed.
    4. Push the Diagnostic button to exit

    PSG
    poolschoolgrad

    20x40 free-form IG vinyl, 1hp Hayward superpump, Hayward pro grid DE filter, Raypak heatpump, Goldline Aquarite SWCG, Polaris 280 with booster, and tested using a Taylor K2006.

  12. Back To Top    #12

    Re: High Salt light on the Aqua Rite system remains on

    Thanks!

  13. Back To Top    #13

    Join Date
    Jun 2011
    Location
    Nj
    Posts
    57

    Re: High Salt light on the Aqua Rite system remains on

    my salt level shows 4100 and no high salt light on
    11,000 gal inground fiberglass pool
    Aquarite SWG system

  14. Back To Top    #14

    Re: High Salt light on the Aqua Rite system remains on

    Had all the same trouble...finally read this post and some how the cell was not configured correctly...got it changed to t-15...high salt went out immediately....Funny thing is that I will probably have to add salt now
    24'x52" Opus w/ Portofino J hook liner
    Ecco sand filter w/1.5 hp pump
    Half deck with Biltmore pool steps
    Barracuda 1500 vacuum
    Sunheater 2x20 solar panel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •