Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Older Aquabot turbo

  1. Back To Top    #1

    Older Aquabot turbo

    Power supply is not functioning correctly. I have narrowed it down to the transformer inside. I cannot find what the output voltage of the transformer. Various places on the net say either 24v or 36v. I am more than capable of replacing it if I knew the specs. Thanks
    17,000 gallon IG Humpback Kidney
    333k Sta-Rite Max-e-therm Heater
    Sta-Rite Modular Filter
    Intellichlor IC-40
    Awesome Tiki Bar!!!!!

  2. Back To Top    #2

    Re: Older Aquabot turbo

    Does anyone have one of these older aquabots? Could you possibly measure the output voltage?
    17,000 gallon IG Humpback Kidney
    333k Sta-Rite Max-e-therm Heater
    Sta-Rite Modular Filter
    Intellichlor IC-40
    Awesome Tiki Bar!!!!!

  3. Back To Top    #3

    Join Date
    Oct 2010
    Location
    Eastern TN
    Posts
    172

    Re: Older Aquabot turbo

    I don't have one but these folks will answer your question: http://www.aquaqualitypools.com/
    Good luck...
    Plaster pool inground 22,000 gallons with spa. Pentair Intelliflo, IC40 salt generator, WiFi control/Easy Touch.
    Hayward 1.5 HP pump on 750 gallon spa. Sand filters. Auto chlorinator on spa. Auto water level. Dolphin M500. TF100 XL with Speed Stir. Apera Instruments AI311 PH60 Premium Waterproof pH Pocket Tester

  4. Back To Top    #4

    Join Date
    Jul 2011
    Location
    Edison, NJ
    Posts
    3

    Re: Older Aquabot turbo

    I just bought a new power supply for my aquabot turbo and then the robot itself died.
    Ended up buying a new pool cleaner.
    Will sell you the power supply if you are interested.

    John
    [center:1v9oz073]25,000 Gal Cement pool
    Hayward 20GPM Sand Filter
    Hayward 1HP pump
    [/center:1v9oz073]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •