Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Clearwater LM2-24 - salt cell on the way out?

  1. Back To Top    #1

    Join Date
    May 2010
    Dallas TX

    Clearwater LM2-24 - salt cell on the way out?

    I have a Clearwater LM2-24, 4-6yrs old (came with house).

    The problem started this season: the 'low salt' light is on and the unit will not go above 40-60% output. Manual calls for about 3600ppm (iirc), and the pool is at 3800-4000ppm (test with strips and chemical test to verify. Water temp is 80+. Did not have this issue last year.

    Cell is clean, no buildup. I cleaned it when first bout the house (light buildup) and this spring (minimal buildup).All water chemistry is normal. I cleaned the connection and made sure they are tight. Unit is undersized, the 24 model on a 33k pool. P/O ran 12-18hrs a day, I had been running 10-12 hrs/day at 100% to get adequate output.

    Is this a sign of an old cell, or something else?
    33k Gunite, CompuPool CPSC48 SWG, Sta-Rite System 3 DE, 2.25hp dual-speed, POOLVERGNUEGEN Pressure-side

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: Clearwater LM2-24 - salt cell on the way out?

    Yes, those are all signs of a cell that is starting to wear out.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts