Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: water leaking in connecting tube from pump to filter

  1. Back To Top    #1

    water leaking in connecting tube from pump to filter

    I'm trying to open the pool for the year..I just bought a salt free system but the connection from the salt water system to the filter is leaking. The connection is a threaded connection inside on the filter and outside threaded going to the salt water system. I have tried taping it several times and have made sure the fitting were tight. It is still leaking just a little and I have tried five times reseating and re-taping the connectors. Any other ideas? Thank you in advance

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,338

    Re: water leaking in connecting tube from pump to filter

    It'll help if you can post a picture of the leak. Pipe paste for plastic pipes is probably better at sealing a leak than t-tape is. I'd try that next.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Re: water leaking in connecting tube from pump to filter

    Thanks alot I will try that next.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •