Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Polaris Autoclear Plus

  1. Back To Top    #1

    Join Date
    May 2011
    Annapolis, Maryland

    Polaris Autoclear Plus

    Hi, I am having a code display of 91 and occasionally 92, the salt light indicator is reading "very low" although my salt test at the pool store is 3250 ppm but I
    also have zero chlorine so clearly something is not right.
    Is it difficult to remove the cell and clean myself, or should I make a service call?
    I should say that at closing I had the cell cleaned but not sure the guy knew what he
    was doing. Could something else be wrong with it other than needing to be cleaned?

    Thanks in advance.
    30,000 gal
    salt generating
    sta-rite modul filter

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: Polaris Autoclear Plus

    You should examine the cell. It is easy to tell if it really needs to be cleaned. Open up the unions, look in from one end and examine the plates. If you see any white crusty stuff, it needs to be cleaned. If you don't then something else must be going on. Cleaning it isn't too difficult, you can probably do it yourself.

    Remember that you need to be adding chlorine one way or another while you work out what is going on with the cell.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts