I am new to this site. It looks great.

I have a Pentair Mastertemp 400 heater, 4000 series filter and a Sun Touch control pannel. The spa will not work with the heater all of the sudden. I push the spa button on the Sun Touch pannal and on the heater I get 888, 128, r=8, then the spa LED is lit and the service system LED is lit. The spa blower will not run. If I hit AUX 2 on the Sun Touch then the Spa Blows as it should but no Heat is Runnning. I have cleaned and backwashed the filter and added new DE per the instructions. If I turn on the heater for the pool, the heater comes on and heats the pool. Where am I going wrong?

Already Tried:
I have tried starting the blower on AUX 2 and then turning on the heat with the Sun Touch pannell and no joy. As a matter of fact, no lights come on on the heater at all when I do this. I have cleaned the filter system and backwashed and added new DE. Pressure is 10-15 LBS at the valve. I have tried turning off AUX 2 (the spa blower) and starting the spa with the SPA quick touch button on the Sun Touch. The heater lights then flash as first described, valves turn but no spa blower.

Thanks in advance!