Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Problem with DIG 220

  1. Back To Top    #1

    Problem with DIG 220

    Rookie here- not to owning the pool but to trying to self address some maintenance issues. I'm on a 7 year old DIG 220, I've replaced the cell once about 4 years ago and the control panel about 3 years ago. Have had Low Amp- Cell? message since late last summer so I went all winter (Orlando Florida) using manual feed chlorine rather than replace the cell going into off season( disconnected the system so it wouldn't run at all) .

    Now I'm trouble shooting the system and am perplexed. Cell looks relatively good. No scale buildup that I can see. I scrolled through menus and saw that the system was set up for wrong cell- it was on 48 as opposed to 36 which I have so I changed that. Brought salt up to about 3600 and am still getting the same error. I tried to boost and then to force reverse and no new outcomes.

    Manual says that power supply could be my issue if it's not the cell. Is there a good way to check either of these?

    Assuming I need to replace cell I saw a generic on the market for just under $200, wonder if anyone has tried that or has perspective??

    Thanks in advance- I'm not much of a DIY guy so I'm looking forward to learning more from this forum

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Problem with DIG 220

    Try pressing boost, waiting a minute, then do a Test Pool Pilot, and post the amps and volts that it reports.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Re: Problem with DIG 220

    Thanks for the reply- I took those steps and see it @ 28 V 1.8A

  4. Back To Top    #4
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Problem with DIG 220

    Those numbers are suggestive of a cell that is wearing out.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  5. Back To Top    #5

    Re: Problem with DIG 220

    Thanks Jason. You have any experience with the generic version of these cell that are selling on E-bay?

  6. Back To Top    #6
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Problem with DIG 220

    They are fairly new, so we don't know much yet. I've heard two complaints and several "mine works fine". Remember that using a generic cell replacement voids your warranty (if you have any warranty left).
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  7. Back To Top    #7

    Re: Problem with DIG 220

    again- thanks for your input. I'll let you know how it plays out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •