Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 12 of 12

Thread: Help! problem with my barracuda G3

  1. Back To Top    #1

    Help! problem with my barracuda G3

    Ok, here's my problem. I just opened up my pool and was using my G3, it will only work for a few minutes, then the pressure in my filter ( Hayward sand filter)
    rises to 26 from 18 and my my pump stops suctioning. I turn off the pump then turn it back on and the same thing happens. It sucks fine for the few minutes then stops again, there is nothing in the hose or at the end of the G3 that might clog the system . My pump works great when I don't have it attached. I am hoping one of the guru's here on the forum can give me some advice.
    Thanks
    18x36, IG, Vinyl, 25,000 gal, S-200, 3/4 Super Pump, BBB or bust!
    I have a new bottom, new plumbing, and everything is working good!

  2. Back To Top    #2
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,199

    Re: Help! problem with my barracuda G3

    Did you empty the pump strainer basket? Check the G3 again and make sure nothing is stuck in the diaphragm. Have you backwashed the filter?
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  3. Back To Top    #3

    Re: Help! problem with my barracuda G3

    I have emptied the strainer basket, once it was full another time there was nothing but a few leaves. I also checked to make sure nothing was in the diaphragm, I pulled it apart just to make sure. I have backwashed the filter as well, just to make sure.
    18x36, IG, Vinyl, 25,000 gal, S-200, 3/4 Super Pump, BBB or bust!
    I have a new bottom, new plumbing, and everything is working good!

  4. Back To Top    #4
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,199

    Re: Help! problem with my barracuda G3

    Did you check all the sections of hose for a clog?
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  5. Back To Top    #5

    Re: Help! problem with my barracuda G3

    Yes, I even used the return jets to blow out anything that might be clogging the hoses
    18x36, IG, Vinyl, 25,000 gal, S-200, 3/4 Super Pump, BBB or bust!
    I have a new bottom, new plumbing, and everything is working good!

  6. Back To Top    #6

    Join Date
    Feb 2008
    Location
    Denton, TX
    Posts
    5,061

    Re: Help! problem with my barracuda G3

    Once it stops, is there any suction at all in the cleaner line or is the suction through the cleaner line completely absent?

  7. Back To Top    #7

    Re: Help! problem with my barracuda G3

    there is no suction whatsoever. It will create suction again once I turn the pump off and on again.
    18x36, IG, Vinyl, 25,000 gal, S-200, 3/4 Super Pump, BBB or bust!
    I have a new bottom, new plumbing, and everything is working good!

  8. Back To Top    #8

    Join Date
    Feb 2008
    Location
    Denton, TX
    Posts
    5,061

    Re: Help! problem with my barracuda G3

    Sounds like you have some sort of obstruction. I cannot think of any other reason as to why it would behave that way.

  9. Back To Top    #9

    Re: Help! problem with my barracuda G3

    Thanks for everyone's help I will keep at it.
    18x36, IG, Vinyl, 25,000 gal, S-200, 3/4 Super Pump, BBB or bust!
    I have a new bottom, new plumbing, and everything is working good!

  10. Back To Top    #10

    In the Industry

    Join Date
    Aug 2007
    Location
    near the swamp
    Posts
    804

    Re: Help! problem with my barracuda G3

    check the impeller for a clog

  11. Back To Top    #11

    Re: Help! problem with my barracuda G3

    Hi - you may have a clog in your vacuum line from pool to pump. Had a similar situation last year and found that my vacuum line was clogged with leaves. Once I cleared the leaves, problem went away. Have you tried putting only one section of hose in the vacuum port (keeping port open) to see if problem still occurs. That is how I found i had a vacuum line clog.
    15k gal, inground plaster, 15'x30', attached spa (w/spillover); Pentair FNS-48 DE filter(using Fiber Clear); w/1.5hp Whisperflo pump; gas heater (MiniMax 250); solar cover; location: El Paso,TX

  12. Back To Top    #12

    Re: Help! problem with my barracuda G3

    I haven't tried that yet, I will try that and see if that helps.
    18x36, IG, Vinyl, 25,000 gal, S-200, 3/4 Super Pump, BBB or bust!
    I have a new bottom, new plumbing, and everything is working good!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •