Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pressure from return

  1. Back To Top    #1

    Pressure from return

    Hi TFPers,
    I have a 24' AGP. I have a 1 HP Hayward Pump and a XStream 1500CC filter. I bought the house in 2009 and have acquired the pool from the previous owners. I have a question about the cartridge filter. It seems that I have a lot lower pressure coming from my inlet than I normally do. I have 3 cartridges that I cleaned by soaking them in dishwasher detergent and then used the muriatic acid to get the additional calcium deposits off. I would have thought that this would have increase the pressure, but it never seemed to get any better. I don't know if my cartridges are shot or if I have other problems. I replaced all my hoses and clamps and tore down everything multiple times. Should it be blowing out with great force or is it supposed to be like 2 streams of water from the bottom of the inlet? I hope this makes sense.
    24' Above Ground Pool, 13,500 GAL, 1 HP Heyward and 1500CC XStream Filter System

  2. Back To Top    #2
    dmanb2b's Avatar
    Join Date
    Apr 2009

    Re: Pressure from return

    Welcome to TFP Any chance you can post a pic? It almost sounds like the plumbing may be reversed somewhere
    24'x52" AGP (13,500 Gallons), Intex SWG, (2)Solar Bear 4x20 panels, Hayward S220T Filter, 1/2hp Pentair Superflo

    Pool School, TFTestKits, Pool Calculator

  3. Back To Top    #3

    Re: Pressure from return

    I can get a picture when I get home. But I can tell you it is rather simple. I have a hose going from my strainer to the pump and then a hose from my filter to the pool inlet. That's it. I thought maybe I had an airleak that is why I changed to new hoses and clamps. To be honest...I think it is worse now with the new hoses. I actually changed the hose from the filter to the inlet with the old one that I was using. I was having a problems with the hose sealing with the inlet. No matter how hard I cranked the hose clamp I still had water trickling from the top of the hose. It seemed to finally stop.
    24' Above Ground Pool, 13,500 GAL, 1 HP Heyward and 1500CC XStream Filter System

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts