Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 12 of 12

Thread: First Time Cleaning Cartridge Filter

  1. Back To Top    #1
    ktdave's Avatar
    Join Date
    May 2007
    Location
    Katy, TX
    Posts
    888

    First Time Cleaning Cartridge Filter

    I didn't need to (no pressure increase), but I was just curious of the process of cleaning my filter cartridges. I have a Pentair Clean & Clear Plus, 420 sq. ft. filter. I was able to disassemble and clean the cartridges no problem. I thought I had reassembled adequately even putting silicone lube on the O-ring. Now the pool is cloudy and there is a slight leak where the cover sits on the filter body. Is this just a learning curve here? Does it take that precise of placement to get it right? Also, why did my pool cloud up?

    I'm sure I can correct these issues, I just wanted some input from those experienced.

    Thanks!
    11,000 gal. gunite w/midnight blue and white pearl PebbleTec
    Intelliflo 4x160 pump
    Intellichlor IC-20 SWG
    Pentair cartridge filter 420 sq. ft.
    Mastertemp 400K BTU heater
    Legend Platinum cleaner
    Pool School
    JasonLion's Pool Calculator
    TF Test Kits

  2. Back To Top    #2
    divnkd101's Avatar
    Join Date
    Mar 2007
    Location
    Pearland, TX (Houston Suburb)
    Posts
    587
    Dave,

    Not familiar with your Pentair but in my case, there is a tension band that wraps around the filter. I am sure yours is similar. I snug up the band and then tap (either with a wrench or a rubber mallet) on the band all around the filter. This tends to help snug that thing up. Tighten a little, tap a little..... I too had leaks the first time until I learned the secret. Has not leaked since. Good luck.
    MIKE

    21K Inground Custom w/ Spa (Gunite/Plaster), SWCG, Hayward Northstar, Polaris 280, Hayward Color Logics, Jandy PS-8

  3. Back To Top    #3

    Join Date
    May 2007
    Location
    Baton Rouge, LA
    Posts
    237
    Dave

    I cleaned my filter (same filter as yours).... I didn't use any silicon, but I did tighten/tap/tighten/tap, etc....

    it worked.

    Of course, I did this AFTER my pb's pseudo-plumber had assembled it (and it was leaking.)

    I guess you're quallified to be a plumber for Louisiana'a Ken Corner's Professional Pool too!!

    just kiddin'..... I know you read instructions... so you'd never make it with him.


    If it still leaks after about 2 days, I'd open it, wipe off the oring, the seat, and do the tap and tighten thing again.


    You installed that flowmeter yet?


    still swimming? we swam this past weekend. Lesson: Don't swim with your cellphone in your pocket.

    i see my pool is about 82 right now. seems like my heater increases the temp by about 1 degree every 15 min's or so.

    steve
    18,000 gallon gunite free form, with spa, 4x160, EasyTouch, SWCG, Pentair cartr filter, Colorlogic lights.

  4. Back To Top    #4
    ktdave's Avatar
    Join Date
    May 2007
    Location
    Katy, TX
    Posts
    888
    Steve,
    Haven't done the flowmeter yet. Got a few "honey-do's" in front of that project.

    My water's been hanging in the 83-86 range w/solar cover on overnight, so we're still swimmimg every other day or so. I did kick the heater on last weekend to get to 88 on Sat. Went from 84 - 88 in about an hour.

    Thanks for the advice guys. I'll try the tap-tighten-tap technique when I get home.

    Anybody else have their pool get cloudy after cleaning cartridges? It did clear up after running pump full blast for a couple hours.
    11,000 gal. gunite w/midnight blue and white pearl PebbleTec
    Intelliflo 4x160 pump
    Intellichlor IC-20 SWG
    Pentair cartridge filter 420 sq. ft.
    Mastertemp 400K BTU heater
    Legend Platinum cleaner
    Pool School
    JasonLion's Pool Calculator
    TF Test Kits

  5. Back To Top    #5
    divnkd101's Avatar
    Join Date
    Mar 2007
    Location
    Pearland, TX (Houston Suburb)
    Posts
    587
    Did you clean out all of the junk that accumulated at the bottom of your filter before you reassembled????? What did you clean your filters with??? Just curious.
    MIKE

    21K Inground Custom w/ Spa (Gunite/Plaster), SWCG, Hayward Northstar, Polaris 280, Hayward Color Logics, Jandy PS-8

  6. Back To Top    #6
    ktdave's Avatar
    Join Date
    May 2007
    Location
    Katy, TX
    Posts
    888
    I took out the plug at the bottom and sprayed everything down on the inside of the filter. Everything seemed to flush out through the bottom.

    I just used a hose with a brass "sweeper" nozzle to clean the carts., no soaking or detergents.
    11,000 gal. gunite w/midnight blue and white pearl PebbleTec
    Intelliflo 4x160 pump
    Intellichlor IC-20 SWG
    Pentair cartridge filter 420 sq. ft.
    Mastertemp 400K BTU heater
    Legend Platinum cleaner
    Pool School
    JasonLion's Pool Calculator
    TF Test Kits

  7. Back To Top    #7
    Guest
    was the water your "sewer water" that might be why, i was told your supposed to soak the cartridge in bleach for an hour or so after you cleaned it all up.

  8. Back To Top    #8
    ktdave's Avatar
    Join Date
    May 2007
    Location
    Katy, TX
    Posts
    888
    Quote Originally Posted by Rollin Thunder
    was the water your "sewer water" that might be why, i was told your supposed to soak the cartridge in bleach for an hour or so after you cleaned it all up.
    was I not supposed to use my sewer water?

    Dag nab it!
    11,000 gal. gunite w/midnight blue and white pearl PebbleTec
    Intelliflo 4x160 pump
    Intellichlor IC-20 SWG
    Pentair cartridge filter 420 sq. ft.
    Mastertemp 400K BTU heater
    Legend Platinum cleaner
    Pool School
    JasonLion's Pool Calculator
    TF Test Kits

  9. Back To Top    #9

    Join Date
    May 2007
    Location
    Baton Rouge, LA
    Posts
    237
    I don't know what RT has against swimming in sewerage water...


    geez.... mine is salt, so its slimy already.
    18,000 gallon gunite free form, with spa, 4x160, EasyTouch, SWCG, Pentair cartr filter, Colorlogic lights.

  10. Back To Top    #10
    Guest
    Quote Originally Posted by stevenbrla
    I don't know what RT has against swimming in sewerage water...


    geez.... mine is salt, so its slimy already.
    no im kinda jelous, i mean i would love that price, to fill his pool cost less than my average monthly bill pool or no pool. 8)

  11. Back To Top    #11

    Join Date
    Jul 2007
    Location
    Rockville, CA
    Posts
    99
    I too recently cleaned my cartridge filter for the first time and experienced cloudy water for a few hours. My manual noted this is normal with a cartridge filter as it takes a short time for the filter to develop a coating that will once again catch the debris that moves through. Sounds like your cleaning went "by the book."
    20K inground gunite w/ Aqua Logic automation and chlorination Sta-Rite 400 K natural gas heater and cartridge filter 2 HP pump 1.5 HP spa bubbler for spillover spa 1 HP dedicated Letro Legend cleaner
    H2O: two parts Heart and one part Obsession. ~Author Unknown

  12. Back To Top    #12
    ktdave's Avatar
    Join Date
    May 2007
    Location
    Katy, TX
    Posts
    888
    Thanks flintstone, good to know.
    11,000 gal. gunite w/midnight blue and white pearl PebbleTec
    Intelliflo 4x160 pump
    Intellichlor IC-20 SWG
    Pentair cartridge filter 420 sq. ft.
    Mastertemp 400K BTU heater
    Legend Platinum cleaner
    Pool School
    JasonLion's Pool Calculator
    TF Test Kits

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •