Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Green water with tree debris

  1. Back To Top    #1

    Green water with tree debris

    I have an above ground pool with a salt system. I didn't run the pump during the winter. The water is very green and has a lot of debris from trees. When I turn the pump on, very little water flows through. What should I do? Do I have to drain the pool and start over? Thanks.

  2. Back To Top    #2

    Join Date
    Aug 2010
    Dallas, TX

    Re: Green water with tree debris

    Time to visit Pool School and go through the shock process!

    Your low flow could be caused by a variety of issues; blocked skimmer/drain, blocked pump basket, dirty filter, etc.

    The more information you can post, the better. What kind of pool, size, filter, etc.
    Built in 1957 44,000 gallon in-ground, Wet Edge Primera Stone in Sky Blue, Intelliflo VF Pump, 600 lb. Pentair Triton II TR-100 Sand Filter, CircuPool RG 60 Plus SWG, TF-100 test kit
    If TFP has helped you, please click to SUPPORT TFP!

  3. Back To Top    #3
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: Green water with tree debris

    Welcome to TFP!

    Can you tell us more about your pool? Do you know what kind of filter you have? Do you know your current water test results? Is it vinyl, concrete, or fiberglass?

    There is no need to drain the pool. Start by scooping out everything you can with a leaf rake.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts