Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Problem with Sta Rite Max E therm heater.

  1. Back To Top    #1

    Problem with Sta Rite Max E therm heater.

    Hi All,
    My six year old Max E therm still works great but the "temperature up" button doesn't work. All the other buttons work fine and the heater also works well. They sell a replacement membrane which is $75 or the entire control board kit for $250. Not sure which way to go and would hate to start swapping parts for nothing. Any ideas? My gut says to buy the kit that way I'm not messing around with wafer thin membranes but wanted some thoughts first.
    Thanks,
    Joe
    15,500 gal, inground gunite pool with 7 ft spa, 2 speed pump 2hp/.33hp, 3/4 hp booster pump, Intermatic P1353 timer, AutoPilot SC-48, Sand filter with ZeoBest, Heater, that I never use . . .

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Problem with Sta Rite Max E therm heater.

    It all depends on how comfortable you feel replacing parts. A replacement membrane should take care of it.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Mar 2007
    Location
    Coastalish 'down easter'
    Posts
    4,160

    Re: Problem with Sta Rite Max E therm heater.

    Cruz, I hope all else is well!

    Before you go spending $ on that - try to blow some compressed air into the pad (spiders tend to build their nests in the gap there). Of course you'll have to remove the mother board to get there and just use a can of compressed air (like the ones my wife uses to clean out our keyboards).
    Luv& Luk
    -Ted

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

  4. Back To Top    #4

    Re: Problem with Sta Rite Max E therm heater.

    Waste, sounds like a good idea. I'll give it a go and see what hgappens. I'll let you know.
    Joe
    15,500 gal, inground gunite pool with 7 ft spa, 2 speed pump 2hp/.33hp, 3/4 hp booster pump, Intermatic P1353 timer, AutoPilot SC-48, Sand filter with ZeoBest, Heater, that I never use . . .

  5. Back To Top    #5

    In the Industry

    Join Date
    Mar 2011
    Posts
    441

    Re: Problem with Sta Rite Max E therm heater.

    Quote Originally Posted by cruzmisl
    Waste, sounds like a good idea. I'll give it a go and see what hgappens. I'll let you know.
    Joe

    If you are brave you can find the common pin, then the temperature up pin on the membrane, and jump it with a wire to test it.

    There should be 6 pins on the ribbon cable 1 common, pool, spa, off, up, and down.

    There is no risk shorting the ribbon pins unless you short them to something else on the board.
    20X40 30,000 gallon gunite pool

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •