Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Pump whisper flow

  1. Back To Top    #1

    Pump whisper flow

    My pump is not working and is making a loud humming sound. Is there a way to disassemble safely. I have a Lab and he is alway swimming year round and basket has hair in freq. Help if you know how to fix or trouble shoot

  2. Back To Top    #2
    bobodaclown's Avatar
    Join Date
    Apr 2011
    Location
    Murrieta, CA
    Posts
    2,360

    Re: Pump whisper flow

    Shut off, disconnect power. Check impeller blades for blockage.
    Murrieta, CA. 15K (Est) pool/spa. Hayward Tristar SP3220EE 2.70HP pump, Hayward Swimclear Cartridge filter C4025 425sqft (PA106), Pentair Mastertemp 400 heater. TF-100/Speedstir

  3. Back To Top    #3

    In the Industry

    Join Date
    Mar 2011
    Location
    Scottsdale, AZ
    Posts
    406

    Re: Pump whisper flow

    Humming can also mean a bad capacitor.
    Once you get if fixed, purchase some skimmer socks, they will catch the fur prior to it going to the pump.

  4. Back To Top    #4
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Pump whisper flow

    Welcome to TFP!

    Sometimes just turning the motor shaft by hand a few turns, with the power off, will solve that problem.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •