Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pump problems

  1. Back To Top    #1

    Pump problems

    hi all - I have a Magiline salt-water/chlorinator-cell pool which is about 5years old.

    Since Spring has arrived, I've started to clean it ready for the first swim.

    However, the pump keeps tripping the RCD fusebox - I've cleaned all three filters cartridges and even removed the pump to check there's nothing caught in it (there wasn't).

    A couple of queries:
    1. the pump says 'please bleed air if it has been removed' but there's no bleed valve - anyone know how to bleed a Magiline pump?
    2. I've still no idea why the fuses keep tripping - switched off everything except the pump but it still runs for no more than 10seconds. Any ideas welcome!


    34 x 19 salt water free form. 7.5" inside diameter raised spa. 24" raised beam in back. 3 moss rock waterfalls off raised beam and moss rock waterfall out of the spa. (2) Intelliflo VF pumps, 420 Cartridge Filter, 400 BTU Pentair low nox heater. 2.5" suction and 2" returns throughout.

  2. Back To Top    #2
    Melt In The Sun's Avatar
    Join Date
    Oct 2009
    Tucson, AZ

    Re: Pump problems

    You bleed the air from the filter; there should be a little plastic screw at the top for that.

    Not sure about the pump, but I know some people around here can help you. It's a common problem with pumps, I just can't remember what it means right now
    11,200 gal, Pebble-Tec; Tristar 2-speed 1hp - Swimclear 325 ft2 cart - SWG - A & A in-floor cleaner - Heat pump. For the poolside cooking, a Yoder Wichita and a Big Steel Keg!
    TF Test Kits -- PoolMath -- Pool School
    Make each day your masterpiece. - John Wooden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts