Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Leaking Multi-port Valve

  1. Back To Top    #1

    Join Date
    Jul 2007
    Location
    Austin, TX
    Posts
    61

    Leaking Multi-port Valve

    I have a Pac Fab multi-port valve model SP-712-2 that is leaking from the top. After a little research I'm thinking I need to replace an O ring. Do I need the "GO KIT 10 Universal 5-SPOKE Multiport Rebuild Kit SP-710X / SP-712 (after 1976)" (http://www.poolcenter.com/go_kits_by...valve_kits.htm)? Is this a simple fix?
    I was intimidated by my Polaris until I watched a You Tube video on how to rebuild one. Now I'm comfortable changing out bearings, etc. I've never touched the valve though and want to make sure I know what I'm doing before I start taking it apart. I can't not have that working!

    Thanks for your help in advance!
    26K IG plaster pool, 2 Baker Hydro Skimmers (Model HS), 4 return jets (one plumbed with a PoolSkim surface cleaner), Hayward 1.5 6-way Multiport Valve (Sp710x-All), Polaris 380 w/ Polaris PB4-60Q Halcyon 3/4 HP Booster Pump, Pentair SuperFlo 1.5 HP (1.65 SFHP) Two Speed Pump (SF-N2-1-1/2A), Stainless Steel Hayward vertical DE 36ft2 filter (Duralon tank model DE3600), Purex CHD Pool Star light, 2 Intermatic mechanical time switches controlling the filter pump and booster pump, Hasa 8 gallon 3/8" Pool Liquidator Chlorinator, 1.5" return line with 3 x 1.5" suction lines, Austin, TX

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Leaking Multi-port Valve

    The GO Kit will have the o-ring you need, which can also be found separately. Mutli-port servicing is simpler than Polaris servicing, so it should be easy for you. There are videos around on YouTube if that helps.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Jul 2007
    Location
    Austin, TX
    Posts
    61

    Re: Leaking Multi-port Valve

    I got it fixed. The spider gasket was bent and not seating properly causing the leak. I got the GO KIT 10 and replaced all the gaskets except the little shaft O-ring. I couldn't figure out how to remove the old one. If anyone knows how please tell me. I found a YouTube video on how to replace a spider gasket (http://www.youtube.com/watch?v=PNyQZEhwdoE). However, I also found a site that described how to replace most of the gaskets (except the little O-ring) at: http://www.poolrepair.com/archive/spider.html. Contrary to conventional wisdom this site recommended NOT gluing the spider gasket and, instead, just use some waterproof grease to help it seal. It tried that, thinking I could just go back and glue it if it didn't work. Seems to be working fine so far.

    Thanks for all the help!
    26K IG plaster pool, 2 Baker Hydro Skimmers (Model HS), 4 return jets (one plumbed with a PoolSkim surface cleaner), Hayward 1.5 6-way Multiport Valve (Sp710x-All), Polaris 380 w/ Polaris PB4-60Q Halcyon 3/4 HP Booster Pump, Pentair SuperFlo 1.5 HP (1.65 SFHP) Two Speed Pump (SF-N2-1-1/2A), Stainless Steel Hayward vertical DE 36ft2 filter (Duralon tank model DE3600), Purex CHD Pool Star light, 2 Intermatic mechanical time switches controlling the filter pump and booster pump, Hasa 8 gallon 3/8" Pool Liquidator Chlorinator, 1.5" return line with 3 x 1.5" suction lines, Austin, TX

  4. Back To Top    #4

    Join Date
    Jul 2007
    Location
    Austin, TX
    Posts
    61

    Re: Leaking Multi-port Valve

    Just thought I'd update this old post with some new information in case someone is looking to solve a similar problem. The leaking stopped after I replaced the spider gasket; for a while. However, the leaking started again after a few years so I thought, no problem, I'll just fix the gasket again. Didn't work this time. While performing a major overall of my pump station recently I finally just took the whole thing out and brought it to the pool store to make sure I got a matching new one. The guy at the store pointed out a hairline crack that was causing the leak. It was pretty obvious when you knew what to look for. So, this is just a reminder to not overlook the obvious. If your valve is leaking and a new GO KIT doesn't fix it look for a crack.
    26K IG plaster pool, 2 Baker Hydro Skimmers (Model HS), 4 return jets (one plumbed with a PoolSkim surface cleaner), Hayward 1.5 6-way Multiport Valve (Sp710x-All), Polaris 380 w/ Polaris PB4-60Q Halcyon 3/4 HP Booster Pump, Pentair SuperFlo 1.5 HP (1.65 SFHP) Two Speed Pump (SF-N2-1-1/2A), Stainless Steel Hayward vertical DE 36ft2 filter (Duralon tank model DE3600), Purex CHD Pool Star light, 2 Intermatic mechanical time switches controlling the filter pump and booster pump, Hasa 8 gallon 3/8" Pool Liquidator Chlorinator, 1.5" return line with 3 x 1.5" suction lines, Austin, TX

  5. Back To Top    #5
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Leaking Multi-port Valve

    Is the crack something that is visible in a picture? Or are they certain places where the crack may be typical?

    Wondering if we can learn what to look for.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  6. Back To Top    #6
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,331

    Re: Leaking Multi-port Valve

    It would be great if you could post a picture of the crack.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  7. Back To Top    #7

    Join Date
    Jul 2007
    Location
    Austin, TX
    Posts
    61

    Re: Leaking Multi-port Valve

    Sorry, I didn't notice the replies earlier asking about the crack. Unfortunately, I threw out the old valve. The crack was literally the thickness of a strand of hair (aka a "hairline" crack). I think it ran along the short section of the threaded return line sticking out from the side. My guess is that I may have caused it by overtightening the joint when I installed a new return line pipe (which I did when I added a port for my liquidator).
    26K IG plaster pool, 2 Baker Hydro Skimmers (Model HS), 4 return jets (one plumbed with a PoolSkim surface cleaner), Hayward 1.5 6-way Multiport Valve (Sp710x-All), Polaris 380 w/ Polaris PB4-60Q Halcyon 3/4 HP Booster Pump, Pentair SuperFlo 1.5 HP (1.65 SFHP) Two Speed Pump (SF-N2-1-1/2A), Stainless Steel Hayward vertical DE 36ft2 filter (Duralon tank model DE3600), Purex CHD Pool Star light, 2 Intermatic mechanical time switches controlling the filter pump and booster pump, Hasa 8 gallon 3/8" Pool Liquidator Chlorinator, 1.5" return line with 3 x 1.5" suction lines, Austin, TX

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •