Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: AutoPiloot Digital not working

  1. Back To Top    #1

    AutoPiloot Digital not working

    At the end of last season when i powered up the auto pilot the red light would flash a few seconds then display would come up. I think it was pool pilot with the software version number, and that is all it does. Control pad does nothing.
    Any ideas? please!

    thanks Dave H.
    20000 gal IG fiberglass, 1 HP Speck pump, Astral sand filter

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: AutoPiloot Digital not working

    Welcome to TFP!

    When you turn it on it goes through a short self test procedure, red light flashes, and then a couple of different things are displayed, each for a short time, and finally it comes up and you can use the controls. On some of the older units, if the internal battery is dead, it will only turn on all the way every other or every third time. Try cycling power again and see if anything is different.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Re: AutoPiloot Digital not working

    Sorry forgot to tell you I have tried a couple of dozen times by tripping the breaker. always the same result.
    20000 gal IG fiberglass, 1 HP Speck pump, Astral sand filter

  4. Back To Top    #4

    Join Date
    Apr 2007
    Ft Lauderdale, Florida

    Re: AutoPiloot Digital not working

    DaveH, its possible that the plastic stand offs that hold the circuit board to the cover are broken, so that when you press any button, the board pushes away and does nothing.
    Turn the power off and remove the top cover. Disconnect the wire harnesses and inspect the circuit board. There are 4 screws holding it down. If you remove them, you will see the stand offs. Also, while you have the board off, press the buttons to make sure they are operating freely, and not obstructed with debris.

    Do you have a display at all?
    Sean Assam -
    National Accounts and Commercial Products Manager
    AquaCal Heat Pumps
    AutoPilot Salt Chlorine Generators

  5. Back To Top    #5

    Re: AutoPiloot Digital not working

    The standoffs are ok. When I power up it runs throught its test cycle, display reads "remote compatible" red light flashes 15 times then display reads
    "Pool Pilot
    Digital v 4.02"
    no fans no nothing just the display I just wrote.
    20000 gal IG fiberglass, 1 HP Speck pump, Astral sand filter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts