Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 9 of 9

Thread: Speed Stir

  1. Back To Top    #1

    Join Date
    May 2010
    Location
    SW Georgia
    Posts
    298

    Speed Stir

    Has anyone had the light go out in their Speed Stir? Can the bulb be replaced?
    35K IG Vinyl 20 x 40 self built pool, Hayward Pro Series High-Rate Sand Filter 31" 98gal/min, Hayward TriStar 1.85hp, Hayward 400btu heater, BBB method w/Hypo, Jazz light w/matching fiber optic rope lighting around coping w/syncronized color wheels. Concrete Paver deck.

  2. Back To Top    #2

    Join Date
    Mar 2010
    Location
    Spring, TX
    Posts
    1,082

    Re: Speed Stir

    Hopefully someone will be along to answer your questions. Dont you just love the speed stir. I have tried to use the light option a few times, but seems harder to use with the light on.

    I think it is made by taylor.

    So you may want to check out their site and email them

    http://www.taylortechnologies.com/home.asp

    Here is the part on their site to refer to

    http://www.taylortechnologies.com/produ ... artID=2300
    13,000 Plaster IG Pool approx
    Hayward C5030 Cart Filter
    Emerson 1081 EB653 1.0 HP 1.40 S.F. 3450 RPM
    Pool Calculator, Pool School, TF Test Kits

  3. Back To Top    #3
    Melt In The Sun's Avatar
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Posts
    3,899

    Re: Speed Stir

    It's a bunch of LEDs, not a single bulb. I bet there's a loose wire somewhere, and if you can get the thing open it shouldn't be too difficult to figure out where the problem is.
    11,200 gal, Pebble-Tec; Tristar 2-speed 1hp - Swimclear 325 ft2 cart - SWG - A & A in-floor cleaner - Heat pump. For the poolside cooking, a Yoder Wichita and a Big Steel Keg!
    TF Test Kits -- PoolMath -- Pool School
    Make each day your masterpiece. - John Wooden

  4. Back To Top    #4
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: Speed Stir

    Check the batteries. Unlike old fashioned light bulbs that get dimmer and dimmer, LEDS work down to a certain voltage then just stop.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  5. Back To Top    #5
    Woodberg's Avatar
    Join Date
    Apr 2009
    Location
    Houston, TX (Candlelight Estates)
    Posts
    136

    Re: Speed Stir

    My speed stir doesn't stir, it just vibrates in the bottom and agitates the water. Is this the way its supposed to work or should it actually be spinning?
    20,000 gallon gunite pool, attached spa, Pebblesheen finish, Paramount PCC-2000 infloor cleaning system, Paramount ClearO3 ozone system, Intelliflo VS main pump, Whisperflo 1HP cleaner pump, StaRite cartridge filter, StaRite heater

  6. Back To Top    #6
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Speed Stir

    It should actually be spinning. First thing to do is change the battery with a known good one. Then try a different magnet.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  7. Back To Top    #7

    Join Date
    Mar 2010
    Location
    Spring, TX
    Posts
    1,082

    Re: Speed Stir

    Quote Originally Posted by Woodberg
    My speed stir doesn't stir, it just vibrates in the bottom and agitates the water. Is this the way its supposed to work or should it actually be spinning?
    As already stated, when you put the magnet in the magnet itself should spin. The tube will not spin only the magnet should. If you are not getting any spinning of the magnet, change out the batteries as stated above. Mine was doing the same as yours, changed the batteries and all was back to normal.
    13,000 Plaster IG Pool approx
    Hayward C5030 Cart Filter
    Emerson 1081 EB653 1.0 HP 1.40 S.F. 3450 RPM
    Pool Calculator, Pool School, TF Test Kits

  8. Back To Top    #8
    Woodberg's Avatar
    Join Date
    Apr 2009
    Location
    Houston, TX (Candlelight Estates)
    Posts
    136

    Re: Speed Stir

    I changed the batteries and now its working great again. I didn't realize that weak batterys would do that. Thanks.
    20,000 gallon gunite pool, attached spa, Pebblesheen finish, Paramount PCC-2000 infloor cleaning system, Paramount ClearO3 ozone system, Intelliflo VS main pump, Whisperflo 1HP cleaner pump, StaRite cartridge filter, StaRite heater

  9. Back To Top    #9

    Join Date
    Mar 2010
    Location
    Spring, TX
    Posts
    1,082

    Re: Speed Stir

    Quote Originally Posted by Woodberg
    I changed the batteries and now its working great again. I didn't realize that weak batterys would do that. Thanks.
    yeah I was stumpped as well. New batteries work great.
    13,000 Plaster IG Pool approx
    Hayward C5030 Cart Filter
    Emerson 1081 EB653 1.0 HP 1.40 S.F. 3450 RPM
    Pool Calculator, Pool School, TF Test Kits

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •