Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 8 of 8

Thread: Impeller - is this my problem?

  1. #1
    Junior Member
    Join Date
    May 2010
    Location
    Denton, TX
    Posts
    14

    Impeller - is this my problem?

    My pool stopped circulating last week and my strainer pot was not filling with water. Today I took the pump off to see if I could figure out the problem. I have no idea what I'm looking at really, but this doesn't seem right:



    This thing is all beat up


    And this was just sitting on top and it looks all chewed up too


    It seems like the last piece I showed there should be held down by the shaft thing in the first 2 pictures to make it spin. Am I way off here, or have I possibly found my problem?

    Thanks
    16K gal, IG plaster, DE filter, 2.5 HP Pentair Challenger

  2. #2
    Member AClogston's Avatar
    Join Date
    Mar 2011
    Location
    Lincoln, NH
    Posts
    61

    Re: Impeller - is this my problem?

    Yup, the third picture is what's left of your impeller. You'll have to unscrew what's left on the motor shaft and replace it.
    -Alex
    Outdoor Chlorine Pool/Spa (~100' from pump room):(35,000gal IG, plaster, 2 Triton TR-140 sand filters, 2 2HP pumps),(1,200gal IG, plaster, Triton TR-140, 2.5HP pump [circ.], 2 2HP pumps [jets])
    Indoor Bromine Pool/Spa:(24,000gal, plaster, Triton TR-100, 1.5HP SVRS-equipped pump),(3,200gal w/ 3 waterfalls, plaster, Sta-Rite System 3 cartridge filter, 3HP pump [circ.], 3HP pump [jets])

  3. #3
    Junior Member
    Join Date
    May 2010
    Location
    Denton, TX
    Posts
    14

    Re: Impeller - is this my problem?

    Woo hoo!! Now I know the problem.

    Now what do I do? Order a new impeller? Does it go on easy?
    16K gal, IG plaster, DE filter, 2.5 HP Pentair Challenger

  4. #4
    Member AClogston's Avatar
    Join Date
    Mar 2011
    Location
    Lincoln, NH
    Posts
    61

    Re: Impeller - is this my problem?

    Make sure of the pump model and corresponding impeller you need, and order a new one. The part number might be right on the impeller itself.

    They go on really easily. Just hold the opposite end of the motor shaft in place with a wrench and unscrew what's left with channel locks pliers, then screw a new one on hand tight.
    -Alex
    Outdoor Chlorine Pool/Spa (~100' from pump room):(35,000gal IG, plaster, 2 Triton TR-140 sand filters, 2 2HP pumps),(1,200gal IG, plaster, Triton TR-140, 2.5HP pump [circ.], 2 2HP pumps [jets])
    Indoor Bromine Pool/Spa:(24,000gal, plaster, Triton TR-100, 1.5HP SVRS-equipped pump),(3,200gal w/ 3 waterfalls, plaster, Sta-Rite System 3 cartridge filter, 3HP pump [circ.], 3HP pump [jets])

  5. #5
    Junior Member
    Join Date
    May 2010
    Location
    Denton, TX
    Posts
    14

    Re: Impeller - is this my problem?

    Awesome. Thanks man.
    16K gal, IG plaster, DE filter, 2.5 HP Pentair Challenger

  6. #6
    Member AClogston's Avatar
    Join Date
    Mar 2011
    Location
    Lincoln, NH
    Posts
    61

    Re: Impeller - is this my problem?

    Don't mention it!

    Another small item to note, it may be reverse threaded depending on the pump, so if it seems to be unscrewing hard try the other direction. If you still have the manual it will probably have that info.
    -Alex
    Outdoor Chlorine Pool/Spa (~100' from pump room):(35,000gal IG, plaster, 2 Triton TR-140 sand filters, 2 2HP pumps),(1,200gal IG, plaster, Triton TR-140, 2.5HP pump [circ.], 2 2HP pumps [jets])
    Indoor Bromine Pool/Spa:(24,000gal, plaster, Triton TR-100, 1.5HP SVRS-equipped pump),(3,200gal w/ 3 waterfalls, plaster, Sta-Rite System 3 cartridge filter, 3HP pump [circ.], 3HP pump [jets])

  7. #7
    Senior Member
    Join Date
    May 2007
    Location
    South Central NJ
    Posts
    3,203

    Re: Impeller - is this my problem?

    Also order a new set of seals. This will ensure the water will not leak out the back for some time to come.

    Scott
    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  8. #8
    Mod Squad Melt In The Sun's Avatar
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Posts
    3,896

    Re: Impeller - is this my problem?

    Make sure you figure out what got jammed in there while you're at it!
    11,200 gal, Pebble-Tec; Tristar 2-speed 1hp - Swimclear 325 ft2 cart - SWG - A & A in-floor cleaner - Heat pump. For the poolside cooking, a Yoder Wichita and a Big Steel Keg!
    TF Test Kits -- PoolMath -- Pool School
    Make each day your masterpiece. - John Wooden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •