Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 11 of 11

Thread: Rheem Heat Pump problem

  1. Back To Top    #1
    joeg2246's Avatar
    Join Date
    Sep 2009
    Location
    Cocoa, Florida
    Posts
    63

    Rheem Heat Pump problem

    I came home today to find an oily film all over my pool and my spa. I then noticed my Rheem Heat Pump will not come on. I am now assuming something broke loose in there. Any of you had an experience lke this and if so what type of problem do you suspect I may have.
    Appreciate any help,
    Sincerely,
    Joe
    25x15 pool & 5x7 spa, Pentair Easy Touch 8, Pentair Intelliflo, Pentair Ultratemp heater, Pentair C&C 520sqft, Pentair Screen Logic 2, Intellibrite 5G pool & spa lights

  2. Back To Top    #2

    Join Date
    Dec 2009
    Location
    Central Massachusetts
    Posts
    2,690

    Re: Rheem Heat Pump problem

    Oily film, eh? One thing comes to mind and thats the compressor potentially went south, so to speak. The compressor contains an oil to keep it lubricated. If thats what happened, the only fix is a new compressor I'm afraid. Of course i'm just guessing, but be prepared to have it replaced.
    14,000 gallon IG, Vinyl. Hayward 3/4 hp superpump, Penatair IC40 SWCG, Pentair automation, Hayward sand filter, Aqua Comfort heat pump, Hayward 400k Lo-Nox LP heater.

  3. Back To Top    #3

    Join Date
    Oct 2010
    Location
    Georgia
    Posts
    317

    Re: Rheem Heat Pump problem

    Rheem heat pump warranty information
    1-800-260-2758
    poolschoolgrad

    20x40 free-form IG vinyl, 1hp Hayward superpump, Hayward pro grid DE filter, Raypak heatpump, Goldline Aquarite SWCG, Polaris 280 with booster, and tested using a Taylor K2006.

  4. Back To Top    #4
    guamguy's Avatar
    Join Date
    Feb 2010
    Location
    Guam, USA
    Posts
    388

    Re: Rheem Heat Pump problem

    It sounds like the heat exchanger has ruptured internally . The hot refrigerant gas goes through the heat exchanger where it gives up it's heat to the pool water. If it broke, the refrigerant (and oil) would be released into the pool water. How long is your warranty?
    12,800 gallon IG plaster kidney-shaped pool, waterslide, 800 gallon spa.
    1HP 2 speed Sta-Rite pool pump, 1.5 HP Sta-Rite spa jet pump. 2 skimmers, 1 main drain
    Purex-Triton TR-60 325 lb.sand filter. 2" Plumbing, Intex SWCG, TF-100 test kit.
    Link to pics of my pool! http://www.troublefreepool.com/my-oasis-t26558.html

  5. Back To Top    #5

    Join Date
    Dec 2009
    Location
    Central Massachusetts
    Posts
    2,690

    Re: Rheem Heat Pump problem

    Could be the exchanger. My vote is still the compressor though.
    14,000 gallon IG, Vinyl. Hayward 3/4 hp superpump, Penatair IC40 SWCG, Pentair automation, Hayward sand filter, Aqua Comfort heat pump, Hayward 400k Lo-Nox LP heater.

  6. Back To Top    #6
    no-mas's Avatar
    Join Date
    Jun 2008
    Location
    FL
    Posts
    405

    Re: Rheem Heat Pump problem

    Quote Originally Posted by guamguy
    It sounds like the heat exchanger has ruptured internally . The hot refrigerant gas goes through the heat exchanger where it gives up it's heat to the pool water. If it broke, the refrigerant (and oil) would be released into the pool water. How long is your warranty?
    x2

    Call rheem at the number poolschoolgrad posted... the heat exchanger might have a lifetime warranty.
    18k gal inground, everbrite finish, 505 sq ft; 1.5 hp two speed whisperflow; rheem 5100ti 100k btu heat pump; 3 sheer descent falls; DE filter; swg (cell out and using trichlor for now)

  7. Back To Top    #7

    Join Date
    Dec 2009
    Location
    Central Massachusetts
    Posts
    2,690

    Re: Rheem Heat Pump problem

    I hope the OP updates with what is wrong here. Compressor or exchanger.
    14,000 gallon IG, Vinyl. Hayward 3/4 hp superpump, Penatair IC40 SWCG, Pentair automation, Hayward sand filter, Aqua Comfort heat pump, Hayward 400k Lo-Nox LP heater.

  8. Back To Top    #8
    joeg2246's Avatar
    Join Date
    Sep 2009
    Location
    Cocoa, Florida
    Posts
    63

    Re: Rheem Heat Pump problem

    Quote Originally Posted by bk406
    I hope the OP updates with what is wrong here. Compressor or exchanger.
    I will certainly let you guys know what happened. I have isolated the heat pump from the system and am now cleaning up the affected areas.
    The plumber only put a bypass valve on the input side of the heater so I am hoping that the output has a check valve to ensure that I am isolated from the oil.
    Do any of you guys know for certain that the output has a check valve or not?

    Joe
    25x15 pool & 5x7 spa, Pentair Easy Touch 8, Pentair Intelliflo, Pentair Ultratemp heater, Pentair C&C 520sqft, Pentair Screen Logic 2, Intellibrite 5G pool & spa lights

  9. Back To Top    #9


    Join Date
    Sep 2008
    Location
    The Woodlands, Texas, USA
    Posts
    243

    Re: Rheem Heat Pump problem

    I also vote on a ruptured heat exchanger.....which may have damaged the compressor coils. Sorry, but sounds like an expensive disaster.

    Please post back what you find out. Would be very interested in knowing what caused such a catastrophic failure.
    IG 24k plaster with overflow spa. Goldline PS-8 SWG. Tristar 0.75 HP filter pump, Polaris 280, large cartridge filter, 400k BTU NG Max-E-Therm HD, SR Smith Turbo Twister, Life Saver pool fence, ORP managed.

  10. Back To Top    #10
    joeg2246's Avatar
    Join Date
    Sep 2009
    Location
    Cocoa, Florida
    Posts
    63

    Re: Rheem Heat Pump problem

    Well I got in touch with Rheem and come to find out I have a 100% parts and labor warranty through Nov. 2011 and a 100% parts warranty through Nov. 2014.

    They sent a technician out and he determined that the system was breached and was not repairable. They are in the process of getting a new unit that will be installed in about a week.

    I'll post the ultimate outcome once we are installed.

    Thanks for all the help,
    Joe
    25x15 pool & 5x7 spa, Pentair Easy Touch 8, Pentair Intelliflo, Pentair Ultratemp heater, Pentair C&C 520sqft, Pentair Screen Logic 2, Intellibrite 5G pool & spa lights

  11. Back To Top    #11

    Join Date
    Oct 2010
    Location
    Georgia
    Posts
    317

    Re: Rheem Heat Pump problem

    poolschoolgrad

    20x40 free-form IG vinyl, 1hp Hayward superpump, Hayward pro grid DE filter, Raypak heatpump, Goldline Aquarite SWCG, Polaris 280 with booster, and tested using a Taylor K2006.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •