Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: New Ecostar pump

  1. Back To Top    #1

    New Ecostar pump

    Hello, I replaced my 1-1/2 hp whisper flow with a Hayward Ecostar about 3 months ago and now I have bubbles on my returns and the pump basket never fills up with water and has bubbles on lid. I tried to turn on solar and with the pump at full speed I can't clear the bubbles from the returns wit solar on, the panels are about 18 foot high on a two story house. I have checked all fittings and put plumbers silicone on both drain plugs on pump and re lubed the pump lid gasket, also I took a hose and ran over the unions and pump but nothing shows up. The whisper flow worked perfect with the same setupI'm stuck! Thank you for your help.
    17500gal plaster pool, 1/12 Whisper flow pump, Pentair DE 48 sq' filter, Hayward PL- P8 pro logic w/ sence and dispense w/ C02, and T15 SWG, color logic pool light, solor system

  2. Back To Top    #2
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,200

    Re: New Ecostar pump

    It is a variable speed pump? You may need to adjust the controls so it runs on a faster setting. What is the max running capacity on the pump? The brochure doesn't translate RPM into horsepower equivalents. I do wonder if it has enough power to run the solar since the brochure states "Auto priming capability with suction lift up to 10 feet above water level.

    One other thing to check is to make sure the water level on the pool is high enough. You might try adding a couple of inches of water and see if that makes a difference.
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  3. Back To Top    #3
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: New Ecostar pump

    That sounds like a suction side air leak. Some possible locations for the leak are the seal around the lid of the pump strainer basket, or the water level too low in a skimmer allowing air to get drawn down, or bad joint where they connected the pump intake pipe, or any of several other less likely possibilities.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  4. Back To Top    #4

    Re: New Ecostar pump

    The ecostar is a variable speed pump and it's rated for 3 hp, i would think it would do better than the 1.5 whisper flow. I checked both unions and the pump lid o ring is well lubed. the pool level is high enough. Thanks
    17500gal plaster pool, 1/12 Whisper flow pump, Pentair DE 48 sq' filter, Hayward PL- P8 pro logic w/ sence and dispense w/ C02, and T15 SWG, color logic pool light, solor system

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •