Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Leak on pump filter?

  1. Back To Top    #1

    Join Date
    Jan 2011
    Location
    North Texas
    Posts
    99

    Leak on pump filter?

    Please forgive me because I am still getting up to speed on all the technical names for things.
    So I was doing my routine of cleaning out of skimmers, energy filter and pump filter ( the one attached to the motor, I noted it was an emerson, and it was just replaced in Sept.) and because I am a freak ( ok, the energy filter will pop off if I don't get that puppy tight enough and it's kinda hard) I always turn everything back on for a few just to make sure all is good. SO, now, when I turn everything back off, the pump filter ( attached to the motor) spews small amounts of water out in about 3 directions. Just for a moments when the pressure is changing, but still not good.
    2 questions,
    1. is this going to give me grief with the temps dipping below freezing for the next few days ( and sigh, more winter precip, I don't know how you northerners do it!), we do have a freeze guard that keeps the pool running anytime it dips below 35.
    2. Does this mean that maybe the O ring is going bad? Seems a bit soon.
    I have taken the lid off several times to make sure I am getting a seal and tightening it well...still get the same results, the after shut off spew!
    Hope ya'll don't get too tired of me and my incessant questions.

    B
    15,000 gallons, Cartridge Filters, IG,

  2. Back To Top    #2
    JesseJames's Avatar
    Join Date
    Sep 2009
    Location
    Florida
    Posts
    64

    Re: Leak on pump filter?

    I am only guessing, but it sounds like you might need some lubricant-sealant around the rubber seal. I had that issue once and when I placed the lubricant on it everything fit tight with no leaks.
    13K Gal., Plaster, SWG, Intellichlor IC 20, Sta-Rite 1 HP Pump, Sta-Rite PLM 300 Filter, Pentair LED, Solar, Screened Enclosure, Great White, TF-100

  3. Back To Top    #3

    Join Date
    Jan 2011
    Location
    North Texas
    Posts
    99

    Re: Leak on pump filter?

    This probably seems like a stupid question, but I found a tube of "pool and spa lube", that's what I use right? ( wouldn't want to make the situation worse!)
    And when you say around the rubber seal, it's that little black ring or more the rim where the lid attaches?
    Thanks
    15,000 gallons, Cartridge Filters, IG,

  4. Back To Top    #4
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,333

    Re: Leak on pump filter?

    The pool & spa lube is what you need. The little black rubber ring is what actually seals it so it's what needs the lube. Be generous!
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  5. Back To Top    #5
    JesseJames's Avatar
    Join Date
    Sep 2009
    Location
    Florida
    Posts
    64

    Re: Leak on pump filter?

    I placed the lubricant around the rubber seal located where the filter cylinder (the thing that holds the filter) fits together. After that my leaks stopped.
    13K Gal., Plaster, SWG, Intellichlor IC 20, Sta-Rite 1 HP Pump, Sta-Rite PLM 300 Filter, Pentair LED, Solar, Screened Enclosure, Great White, TF-100

  6. Back To Top    #6

    Join Date
    Jan 2011
    Location
    North Texas
    Posts
    99

    Re: Leak on pump filter?

    Thanks ya'll! As soon as we thaw out again, I will get that taken care of! I appreciate you talking me through it!
    15,000 gallons, Cartridge Filters, IG,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •