Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Polaris 380 not picking up

  1. Back To Top    #1

    Polaris 380 not picking up

    We have a polaris 380 for our inground pool, 28k gallon.

    The cleaner is about 4.5 years old and recently has not been picking stuff up from the pool bottom. I have counted the rpm's as suggested and they are low, but I cannot figure out how to change them so the rpms increase. I have pulled out the inline filter (the one on the hose) and it wasn't really clogged, though there was some stuff in there, I cleaned it out pretty good. It is rather rusty, don't know if that would have any effect on the rpms on the cleaner.

    I also looked at the disconnect because I had read you could remove some sort of a blue washer-type thing that might increase the rpms. I couldn't look directly into where the disconnect goes because it is in the pool, underwater (obviously) and it is about 28 degrees here. I couldn't feel anything in the disconnect hole, I ran my finger around the inside but it didn't feel like there was anything I could pull out.

    How long should our pool cleaner last? Is it worth having it repaired?

    I also read that the polaris 280 is easier to maintain and fix; will it fit on the same connections that we have for the polaris 380?

    I have had several bad experiences with pool companies and don't really trust them when they quote prices; it seems I can look online and find the parts needing replacement for at least 50% less then they want to charge. I do understand that they need to make money, but the last estimate was for a display board for my heater which I found new, online, for $175 and they quoted me $450.

    Thanks for any help/guidance you can give.
    25,000 gallon saltwater pool with raised spa, Hayward de filter 6020, 2 hp pump, aqualogic PS-8 Controls - Dallas, TX

  2. Back To Top    #2

    Re: Polaris 380 not picking up

    I have a 380 and had a similar problem.

    I found out that the jet that drives the unit was clogged. I had taken it in to be repaired three times and it was never fixed until I got some advice from this board and checked it myself.

    This was my problem:

    Look at this diagram. The unit is propelled by a jet that hits a turbine assembly. This is labeled 15, 18, and 19 in this diagram.

    I do not see the jet on the diagram. If you take the unit apart it will be easy to see but you have to take the top of the turbine housing. Take apart and reassembly is easy.

    I blasted out the jet with a garden hose connected to a jet nozzle that I taped to a plastic soda straw. That allowed me to blast out the jet in reverse. Another board member described using a paper clip but I tried that and it just pushed the debris back and it re-clogged the jet later.

    I do not know if this is your problem.

    Hope this helps.
    "Whatever happened to the guy who drained his whole pool?"
    27,000 gal plaster in-ground
    Compupool 40k SWG from eBay - works great!
    Polaris 380
    Hayward DE
    1.4 HP Hayward Northstar pump
    Two FAFCO Solar Bear panels now heating the pool!

  3. Back To Top    #3

    Re: Polaris 380 not picking up

    It's worth a try, thanks for your reply.
    25,000 gallon saltwater pool with raised spa, Hayward de filter 6020, 2 hp pump, aqualogic PS-8 Controls - Dallas, TX

  4. Back To Top    #4

    Join Date
    Jan 2009
    Cupertino, CA

    Re: Polaris 380 not picking up

    There are maybe 4 different little hoses inside the unit; I've had one pop off or split probably 3 times in 2 years, with predictable loss of oomph. My local shop has a free-labor policy if you bring it in, so it has always been cheap to get it fixed.
    BBB "Intermediate Swimmer"
    IG plaster pool 18.5K gal, Hayward Pro-Grid DE filter, 3/4 HP Hydramax II; Polaris 380, 3/4 HP booster
    AG spa 325 gal, probably Sundance of some kind
    Water testing instructions on one page

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts