Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Teledyne 325 btu Series 2 not firing

  1. Back To Top    #1

    Teledyne 325 btu Series 2 not firing

    My unit will not fire right now at all. Usually, in accordance with the stated directions, I can turn off all power, reset the manual gas valve from on to off and back, turn back on the power, switch the temp control assembly from off to spa, adjust temperature control to max, turn on the filter pump (which is currently in freeze protection) and press heater on. These are the instructions included with the unit to reset it if the gas valve needs to be reset - this usually works to get the unit to fire if something triggered the safety cut off. Now I cannot get the unit to even click and fire. Could it be that the unit is on freeze protection and the filter pump never really gets to turn off? Where is the brain for the unit? The temperature control assembly? It has a mini circuit board on the back.

    I know I need a new temperature control assembly eventually anyway, it is causing some ocassional fluttering of firing when the unit is working correctly - part 15 on this link: ... s2_pg1.htm

    Why is the temp control assembly so expensive? Any other places to get it?

    If all else fails, I can get my friend back over here and we can test everything with a multimeter, I had success with that last year.

    Many, many thanks to everyone!

  2. Back To Top    #2

    Join Date
    Oct 2010

    Re: Teledyne 325 btu Series 2 not firing

    Jandy provides some of the best on-line service documentation.

    Troubleshooting section begins on page 27.

    Here are some simple things to check before you call your friend with a multi-meter.
    Clean the dust, dirt, or lint out of the pilot area. A small can of compressed air works great.
    Check the wiring and all connectors.
    Clean the thermocouple with some fine sandpaper or emery cloth.

    20x40 free-form IG vinyl, 1hp Hayward superpump, Hayward pro grid DE filter, Raypak heatpump, Goldline Aquarite SWCG, Polaris 280 with booster, and tested using a Taylor K2006.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts