Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pentair Minimax NT 400 TSI won't fire

  1. Back To Top    #1

    Pentair Minimax NT 400 TSI won't fire

    Hi guys ... love the forum -- full of so much great info! I used some info on here last year to get a bad thermistor replaced to fix my Minimax after I bought a house with a pool and it worked like a champ ... until now. Now I have a new problem.

    My 400 TSI now no longer fires. The "Power" LED and "Pressure SW" LED both light up green, however nothing else on the control panel light up at all, and the system doesn't fire or respond at all to any button presses on the front. Not even the 3 -digit spot for error codes or the temp -- just dead. Does anyone have any ideas? Could it be a fuse? Circuit board? I'm not sure where to begin.

    Thanks in advance for the help!

  2. Back To Top    #2

    Join Date
    Oct 2010

    Re: Pentair Minimax NT 400 TSI won't fire

    Here is a link to the owners and service manuals for the minimax series heaters. ... n.php?s=28

    Most likely the DDTC control board is faulty.

    Pentair's Technical Service Department: (800) 831-7133

    20x40 free-form IG vinyl, 1hp Hayward superpump, Hayward pro grid DE filter, Raypak heatpump, Goldline Aquarite SWCG, Polaris 280 with booster, and tested using a Taylor K2006.

  3. Back To Top    #3

    In the Industry

    Join Date
    Dec 2008

    Re: Pentair Minimax NT 400 TSI won't fire

    the next circuit checked after the pressure switch is the thermistor. However, you could have multiple issues if your display is blank too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts