Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Intex Sand filter valves not working right.

  1. Back To Top    #1
    crookm11's Avatar
    Join Date
    Jun 2010
    Copperas Cove, Texas

    Intex Sand filter valves not working right.

    Hi Everyone.

    I have the intex sand filter and when I backwashed the filter today, I noticed that when I put the 6 way valve back in the filter position there is water still comeing out the waste port. I always turn off the pump before I move the valve to the different positions. Does anyone know if the valving inside the filter can be fixed? My fiter has never done this until today. Can the valveing be taken apart to fix in the filter? I had to put another intex plunger valve on the waste port and close it to keep the water from leeking out.

    Any help would be great.
    Mark Crook
    13,500 Gallon 24' x 52" Intex Ultra Frame
    Intex Sand Filter and Pump, Intex SWG (All hard PVC plumbed)
    TFTestKit-100---Pool School---The Pool Calculator
    Location: Copperas Cove, Texas --- My Pool Build---Useful Links for Intex Pool Owners

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: Intex Sand filter valves not working right.

    There should be a spider gasket in it and it's relatively easy to replace. You take the top off the multiport to access it.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts