Become a TFP Supporter Welcome to our new server and new forum software. If you have problems logging in to the new system, you should try resetting your password. Click HERE to do that. Pool School
Results 1 to 3 of 3

Thread: Hayward pool vac ultra - tangled hose (with pic)

  1. #1
    Junior Member
    Join Date
    Jan 2009
    Location
    Plano, Texas
    Posts
    19

    Hayward pool vac ultra - tangled hose (with pic)

    Hi all - did a search but didn't see anything exactly like this out there....

    I have a Hayward Pool Vac Ultra (mixed feelings - 2nd unit - when it's good it's great, when it's not, I hate it).

    Regardless, about 2 months ago, it started wrapping the hose into a know every single time it runs. I haven't broken it down completely to check the guts yet - but I assume that's the next step. I can't figure out what changed from the beginning of the season to cause this.

    Thanks for any help!
    Attached Images Attached Images

  2. #2
    Guest

    Re: Hayward pool vac ultra - tangled hose (with pic)

    Change the wings if they are worn, also check the turbine and make sure the bearings are still good.

  3. #3
    Junior Member
    Join Date
    Apr 2010
    Posts
    24

    Re: Hayward pool vac ultra - tangled hose (with pic)

    Had the same problem, one side was noticeably weaker than the other when running (put a hand under each side). Replaced bearings. All good now.

    And, yes, when it's good it's great.
    18000 gallon in- ground fiberglass pool.
    Hayward DE filter, solar heat in sunny San Jose, CA.
    Automatic pool cover.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •