Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Digital Display Is Stuck

  1. Back To Top    #1

    Digital Display Is Stuck

    The digital display on my Pool Pilot Digital by Autopilot Systems is stuck on "Set Time of Day" and I cannot get past it. I have shut off the power supply at the circuit breaker but it keeps coming back to Set Time of Day. Nothing works on the digital pad. Any ideas other than calling the installer? Thanks.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: Digital Display Is Stuck

    Pool Sean will probably be along soon and may have some help for you. If it's still under warranty I'd go ahead and call the installer now.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Join Date
    Apr 2007
    Ft Lauderdale, Florida

    Re: Digital Display Is Stuck

    You may want to remove the front cover and inspect the plastic stand offs that hold the circuit board to the cover. If these are broken, or if a button is stuck in the down position, it can freeze up the display.
    And as Bama Rambler said, if its under warranty, go ahead and cell the installer, or our customer service who can provide authorized service center information to take care of this.
    Sean Assam -
    National Accounts and Commercial Products Manager
    AquaCal Heat Pumps
    AutoPilot Salt Chlorine Generators

  4. Back To Top    #4

    Join Date
    May 2007
    North Texas

    Re: Digital Display Is Stuck

    I also had "set time of day" display stuck after I took my DE filter apart and turned filter on to put more DE in. The pump was on low speed so I didnt want to put the DE in til I got the pump on high speed.
    After finding this post, I took the circuit board off the cover, all stands were good. I pushed each button several times and heard clicks each time. I put it back together and really didnt think it was fixed til I turned it all on and waalaa! I suppose a button was stuck and pushing them directly on the circuit board unstuck it.
    Just an FYI for others with the same problem. Thanks again PoolSean!
    :grin::grin: Yes I am a newbie :grin::grin:

    Grecian 17'x33' Vinyl liner pool
    ZeoBrite filteration
    SWG Aqua-rite
    Sta-Rite Dura-Glas 1.5hp pump.
    SAM Light

    21037.5 gallons

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts