Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Problem with pump

  1. Back To Top    #1

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Problem with pump

    I took some pictures of my pump. I know I need to replace the seals (have not had a chance to) but what is the corrosion at the lower end, is it a small leak and a build up of salt (I have a swg)?

    Also, around the pump basket, there is a leak. I replaced the gasket yet it still leaks. It is the correct gasket, it came with the entire kit. Could there be a problem with the cover, it seems to screw on, and fit snug? I am getting air bubbles in the basket.

    The other picture is of, its seems to be some type of brown stain on the pvc pipe around the fittings. It appeared right after I did the ascorbic acid treatment.

    Any help would be appreciated.
    Attached Images Attached Images
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  2. Back To Top    #2
    embellisher's Avatar
    Join Date
    Jun 2007
    Location
    Heber Springs, Arkansas
    Posts
    31

    Re: Problem with pump

    Is it a clear Lexan cover? In my experience, those can screw on fine and still leak. I have replaced mine 4 times in the last three years. Twice the cover looked fine, screwed on tight, and I had already tried replacing the o-ring.
    Experience is what you get, when you don't get what you want.

  3. Back To Top    #3

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: Problem with pump

    Yes it is a clear cover. Do you have the pentair whisperflow pump? Mine is about 5 years old.
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  4. Back To Top    #4

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: Problem with pump

    Did you replace the the lid and clear cover or just the lid?
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •