Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 17 of 17

Thread: Parts for Autopilot dig 220 Power Circuit Board I can't find

  1. Back To Top    #1

    Autopilot digital low amps

    I am not sure if I am posting this right. I have a message reading Low Amps. I have checked the fuses and all are good. I did notice when I took the cover off the fan was not working. I took it out and soldered the wires and it is now working. Could this cause the system to over heat and break something? The cell is not very old, replced it last year and I did recently clean it. I checked the wires with a volt meter and they are good. I can trace the power going into the board and then no power anywhere else. The unit was installed in 2003. It has been a great system and I have always been happy with it. Money is very tight right now but this has to be fixed. How much does it cost just to have a tech come out? I have been looking for a new board but I have not found the one that looks like mine yet. How much do the boars run? Please help! Bill
    Inground Gunite Pool - Aquarite SWG, Hayward C1200 Cartridge Filter, Hayward Super II Pump, Hayward Colorlogic LED Light System , Central Florida!

  2. Back To Top    #2

    Parts for Autopilot dig 220 Power Circuit Board I can't find

    I found out a tech costs $155.00 just to show up. $55 per half hour. All I want is the Power Circuit Control Board as listed in my owners manual. I seach the internet and I can only come up with a board that does not look like the one I want. It is the L shaped one

    I have a message reading Low Amps. I have checked the fuses and all are good. I did notice when I took the cover off the fan was not working. I took it out and soldered the wires and it is now working. Could this cause the system to over heat and break something? The cell is not very old, replced it last year and I did recently clean it. I checked the wires with a volt meter and they are good. I can trace the power going into the board and then no power anywhere else. The unit was installed in 2003. It has been a great system and I have always been happy with it. Money is very tight right now but this has to be fixed. How much does it cost just to have a tech come out? I have been looking for a new board but I have not found the one that looks like mine yet. How much do the boars run? Please help! Bill

    [attachment=0:29upsz73]CIMG8782 B.jpg[/attachment:29upsz73]
    Attached Images Attached Images
    Inground Gunite Pool - Aquarite SWG, Hayward C1200 Cartridge Filter, Hayward Super II Pump, Hayward Colorlogic LED Light System , Central Florida!

  3. Back To Top    #3
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Autopilot digital low amps

    Note: I only saw the first post when I wrote this reply.
    Please don't ask the same question in more than one place, it only causes confusion.

    Low amps is a typical message to get when the cell is failing or covered with calcium scale. If the cell is 7+ years old, then I would expect it to be at or at least near the end of it's lifetime at this point. You should take the cell out and do a visual inspection of the plates (at least what you can see). There shouldn't be any white chalky stuff and the plates should all be the same length. If there is white chalky stuff the cell needs to be cleaned. If some of the cell plates are shorter than others or have corners that are worn off then the cell needs to be replaced.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  4. Back To Top    #4

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't find

    The cell was replaced 2 years ago and is very clean. I never had any calcium build up. I would think I would have some power coming out of the Power circuit control board if the cell was bad.
    Inground Gunite Pool - Aquarite SWG, Hayward C1200 Cartridge Filter, Hayward Super II Pump, Hayward Colorlogic LED Light System , Central Florida!

  5. Back To Top    #5
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't find

    Yes, you are correct. Most likely the loss of the fan caused overheating which broke something else, as you already surmised.

    You might want to try calling AutoPilot and see what they can do for you. The unit wouldn't be under warranty coverage anymore, but if you send it in for repair they can probably offer you a fairly good price .
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  6. Back To Top    #6

    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    874

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't find

    check those 7 transistors under the heatsink, usually they would be the ones to go as they handle all the current.

  7. Back To Top    #7

    Join Date
    Apr 2007
    Location
    Ft Lauderdale, Florida
    Posts
    1,455

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't find

    The power circuit board only, is not available and is available as a power module, PN# 16084. Where are you located? Regarding an out of warranty service call, those rates are not determined by AutoPilot.
    Did you happen to replace the cell cord at the same time as the cell? IF not, remove and inspect both ends of the cord. The power supply side has banana connectors that may be corroded, which would give you the Low Amp display. If there is corrosion or if it's burnt on the cell plug side, it would cause Low Amps too.
    Check and verify your salt level, and compare it to the DIG display. Add salt and calibrate the unit if needed.
    If you can see obvious damage to the circuit board, particularly to the upper left portion, this is usually not repairable and must be replaced.

    Check with Josh with saltpoolguys.com, who is a member here and offers very good prices to TFP members.
    Sean Assam - Sean@teamhorner.com
    National Accounts and Commercial Products Manager
    AquaCal Heat Pumps www.aquacal.com
    AutoPilot Salt Chlorine Generators www.autopilot.com

  8. Back To Top    #8

    Join Date
    Sep 2010
    Location
    Central Florida
    Posts
    1

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't find

    I have exactly the same thing. My system is four years old. I have replaced the cell three times directly with AutoPilot. I tried to send this one back this summer and AutoPilot is telling me it is not the cell. We cleaned and replaced cord and now we are finding out there is a problem with the circuitboard. I called our local person with AutoPilot and he wants $1,000 to come out and replace the entire box as he says it is impossible to replace just the board. We have put so much money in this system and I am scared to spend that kind of money only to have it happen again. As I talk to people in our neighborhood with this same system, as we all used the same pool company four years ago, they are experiencing the same thing and two have turned their pool into a chlorine system because the cost is too much in this economy. I understand that one of the transitors is burned. Why can't this one transitor be replaced and it work?

  9. Back To Top    #9

    Join Date
    Apr 2007
    Location
    Ft Lauderdale, Florida
    Posts
    1,455

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't find

    It can be a damaged transistor, capacitor, circuit board, or relay. If it will save you money and you're competent to do the work, please do so. Otherwise, as a manufacturer, we really don't want to get into repairing boards, then trying to offer some kind of warrranty with it.
    If you want to send in the unit, we can bench test it for a nominal charge, then if it is repairable, we can provide a quote. Call Customer Service for this option.
    Otherwise, you should be able to just get the Power Module, which is the circuit board with transformer on a metal heat sink plate, or a Chassis Kit, which would be the unit without the cover and display board.
    Sean Assam - Sean@teamhorner.com
    National Accounts and Commercial Products Manager
    AquaCal Heat Pumps www.aquacal.com
    AutoPilot Salt Chlorine Generators www.autopilot.com

  10. Back To Top    #10

    Join Date
    Jul 2007
    Location
    Brisbane, Australia
    Posts
    874

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't find

    DKLIVORSI, the risk you run there is that once something got burned you run the risk of other components breaking very soon after you fix the faulty component. so you might end up having to fix lots of stuff.

    it's fine if you are electronics enthusiast and like doing it, but not something i would recommend for an average SWG owner

  11. Back To Top    #11

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't find

    Just a follow up. We ended up replacing the entire box. I found the cheapest one online for $600.00. It came with new cords to the cell and was very easy to install. I am betting that we saved quite a bit of money. The newer box did come with 2 small fans so I will keep an eye on them to make sure they keep running. I think that is why the last one failed.
    Inground Gunite Pool - Aquarite SWG, Hayward C1200 Cartridge Filter, Hayward Super II Pump, Hayward Colorlogic LED Light System , Central Florida!

  12. Back To Top    #12
    SinistrV6's Avatar
    Join Date
    Sep 2008
    Location
    Mississippi Gulf Coast
    Posts
    111

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't

    I'm having similar issues. I thought I'd post a pic I took of the physical damage to the circuit board in hopes that future searchers might find it useful.

    I, too, had the fans go kaput and replaced them myself. However, the damage may have been done by then. Then again, I've also had TWO lightning strikes at my house (one of which go the display on my pool heater which I still haven't repaired) so some initial damage could've happened at that time.

    Here's the odd thing to me. I've had major issues with an inability to keep FC levels since construction. My first cell was undersized according to my pool builder and they replaced it with a larger one. Problem remained, and I added it to my growing list of reasons "SWG pools SUCK!" Both cells appeared to be working (good voltage, good amps) so I had no reason to doubt that they were functioning. A few weeks ago, the most recent cell "died" and I replaced it with a generic cell. Whoa! FC shot to over 8.5 ! For the first time, I had to turn the power level and the percentage down! So....were those other cells not working? Sure seems that way to me.
    Attached Images Attached Images
    42X16X24 True-L vinyl lined IG pool
    30,500 gallons
    Pool Pilot Digital SWG
    Sand filter

  13. Back To Top    #13

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't

    Same problem here after about 5 years of trouble free use. Keep getting "Check/Clean cell" message. Water chem is perfect. First, I of course cleaned the cell, no change. Then I replaced the cell, no change. Then I replaced the power cord, no change. Then I called an AutoPilot tech who said "Yeah, looks like you may need a new board. It's $800 with installation." Some of those transistors pictured above look like mine where they are pushed out a bit in the center. The cheapest replacement board I've found online (part #16084) is $359 at eSeasonGear.com (free shipping and no tax). So I was going to order this board and would like to know if it's easy to replace myself. How hard is it to swap the boards out, or should I at least pay for a service call for them to come out and replace it for me? Thanks.

    P.S. My in-laws live next door (no jokes, please) and have the exact same system installed at the same time, and are experiencing exactly the same problem. What is it with these systems? Are they "programmed" to fail after 5 years or something? Unbelievable.

  14. Back To Top    #14
    SinistrV6's Avatar
    Join Date
    Sep 2008
    Location
    Mississippi Gulf Coast
    Posts
    111

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't

    At the time mine "died", the 16084 power module was actually about $20 more expensive than an new unit. I bought mine from Josh Ulfers at saltpoolguys.com (as recommended by Sean (see above posts by poolsean). It was more $$ than the price you found for the part though.
    42X16X24 True-L vinyl lined IG pool
    30,500 gallons
    Pool Pilot Digital SWG
    Sand filter

  15. Back To Top    #15
    DaveNJ's Avatar
    Join Date
    May 2007
    Location
    Toms River, NJ
    Posts
    520

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't

    SinistrV6 it appears in your last photo that the capacitors have gone bad. The tops have opened up.
    IG 18x36 oval vinyl, Spill over spa, Northstar 2hp-2spd, 2.5" piping, S310T 500lb Sand filter, 400k gas heater, AutoPilot SWCG
    http://www.tftestkits.net/

  16. Back To Top    #16
    SinistrV6's Avatar
    Join Date
    Sep 2008
    Location
    Mississippi Gulf Coast
    Posts
    111

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't

    Quote Originally Posted by DaveNJ
    SinistrV6 it appears in your last photo that the capacitors have gone bad. The tops have opened up.
    I didn't catch that at the time. Certainly possible.

    As an aside, after replacing the entire unit and the cell, I was able to enjoy my pool for the last year with only minor maintenance! Sooooo different than the first three miserable years.

    Does anyone know if there is a way to determine if there is actual output from the cell other than it's own self-diagnostic? My cells always "appeared" to be working according to voltage and amp readings but until I put this "generic" cell in in 2011, my pool never seemed to be receiving anything from the cell. Since then, my pool has behaved the way my neighbors always bragged that theirs worked.
    42X16X24 True-L vinyl lined IG pool
    30,500 gallons
    Pool Pilot Digital SWG
    Sand filter

  17. Back To Top    #17

    Join Date
    Apr 2007
    Location
    Ft Lauderdale, Florida
    Posts
    1,455

    Re: Parts for Autopilot dig 220 Power Circuit Board I can't

    You can check the voltage (DC) with a multimeter set to DC Volts. Follow the cell cord wires to where it connects to the power module. Slide the terminals up slightly, just enough to get the meter probes on the terminals. You'll need another set of hands to hold the cover so it's not hanging by the wire harness/ribbon connector.
    For amps, you can test this by breaking one line and putting the meter in line, and in the DC Amps mode of your multimeter. Make sure the probes are contacting the terminal and wire before turning it back on, as you can get a little spark when it gets powered up. It's all low voltage dc but BE CAREFUL as you are still dealing with some high voltage 220 volt wires within the control box.
    Sean Assam - Sean@teamhorner.com
    National Accounts and Commercial Products Manager
    AquaCal Heat Pumps www.aquacal.com
    AutoPilot Salt Chlorine Generators www.autopilot.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •