Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Spa Jets have zero pressure...Why? (Pictures of pool/spa)

  1. Back To Top    #1

    Spa Jets have zero pressure...Why? (Pictures of pool/spa)

    So here is the story.
    We were told to have a suction systems hits the Hayward not a Polaris or a pressure system purchase.
    I had a pool guy come out and switch the plumbing for us the pool suction worked great and the realized after
    he left that only one of the jets work now in the hot tub. I know quite a bit about pools and I am at a loss.
    I am thinking it maybe something in the junction boxes for the hot tub jets. Oh we found something in the filters as well
    a cylinder with blue, white and green beads in it.....of course no pool guy has ever heard anything about this contraption.
    Me either.

    One of the pool guys told me it maybe the filters We had the filters checked several times, and we were told they were fine.
    After the 4th pool guy he said he has no idea what it could be but that the warranty company would not cover the jets in the hot tub. We are thinking of switching it back to the old system but would like to just keep the current one and make it work!!

    Please email me or my wife with any suggestions or ideas.

    If you are local and come take a look please call me.

    I need someone here to look at this please.

    Pictures of the system before and after : ... areaz.html

  2. Back To Top    #2

    Join Date
    May 2007
    South Central NJ

    Re: Spa Jets have zero pressure...Why? (Pictures of pool/spa)

    A wider picture of the equipment pad would be helpful. The detail shots will help get put into perspective with the wider angle.

    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  3. Back To Top    #3

    Re: Spa Jets have zero pressure...Why? (Pictures of pool/spa)

    ya I agree. You need some better shots of your return plumbing. I assume since all the valves appear to be manual, you know how to set them for your spa? Can you set them that way and take pics?

    I can tell you right now why your spa is draining during the day. The pool cleaner suction line was tapped off the bottom of the spa suction line. That new 3 way valve at the bottom there is either not fully towards the pool cleaner side during non spa use, or it is leaking such that the spa drain is draining thru that valve in its closed position. This assumes the spa water height is higher than the pool. That new valve looks like a no lube valve, so it should not need lube?

    The other plumbing change he did looks fine. He simply removed the outer valve and the plumbing for the pressure side cleaner since it was no longer needed.

    I think you need to figure out what these colored beads are. Maybe some of those have gotten loose and are blocking your pipe to the jets? Also, you may want to check that check valve in the middle of the pics on the return system, assuming that line is the return to the spa? Maybe it is jamming? If that check valve remains open partially, then that can also cause the spa to drain thru the return down to at least the level of the jets and/or the spa fill outlet (for spa-to-pool overflow setting) or the level of the pool, whichever is greater. When your spa is running, what is the filter pressure?

    dave mc

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts