Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Backflush valve issues...

  1. Back To Top    #1

    Backflush valve issues...

    Several months ago one of the orings on my backflush valve disappeared because the valve hadn't been lubricated. I replaced all of the rings and everything was working fine. A couple weeks after the valve stopped pulling all the way up. I pulled it out to see if there was anything blocking it and didn't see anything. I just set the pump so that it wouldn't automatically turn on and told my mom. At about that point in time someone else started dealing with the maintenance of the pool. He had said he fixed it but about a week ago I had to start maintaining the pool again. The problem was never fixed and all he had done is pulled it out and put an insane amount of lube all over it. Then to keep water from leaking out it looks like he was pulling it up as far as he could and just letting it drip. Now the problem is that since I'm maintaining the pool again I want it fixed. I tried to pull it out earlier, but there is so much lube on it that it feels like its glued in there. I can't pull it out. What is most likely the cause of it not pulling all the way up and how am I even going to get it out to fix it or eventually relubricate it? I'm suspecting the getting it out part is just going to be to keep pulling... But I have no idea how to go about fixing that it won't come all the way up. If you need any more information let me know. Thanks

  2. Back To Top    #2

    Join Date
    May 2007
    South Central NJ

    Re: Backflush valve issues...

    What brand and model are the filter?

    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts