Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 16 of 16

Thread: need new pump

  1. Back To Top    #1

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    need new pump

    I have a whisperflow 1.5 hp pump for my 20,000 gallon IG pool. I need a new one, is this a good pump or do you recommend a different brand? I need input asap. Thanks
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  2. Back To Top    #2
    Guest

    Re: need new pump

    Pentair makes great pumps, and are definitely worth looking at. I would check into either a 2 speed or a multi speed, both of which will save you money on your electrical consumption. Either way you decide to go, I would suggest you look at a 1 HP pump, as the 1 1/2 HP is too much pump for your pool (unless there is something going on beside just a pool that you aren't telling us ).

    The IntelliFlo pumps would be the ones you would look at for speed options, and the WhisperFlo would be the single speed option. Good luck!

  3. Back To Top    #3

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: need new pump

    So I could get a 1 hp pump? I have 2" piping does that matter? Would getting a lower hp pump mean I need to run it longer? One last question, how long before I get algae growing in my pool, I would need a few days to have it shipped and installed?
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  4. Back To Top    #4
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: need new pump

    Yes, you could get a 1 HP pump. You will need to run it longer, but you will still save electricity even though you are running it longer.

    A couple of days is usually enough for algae to get going. I suggest you add some chlorine every day or two by pouring bleach slowly around the edge of the pool and then brushing the entire pool to help it mix in.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  5. Back To Top    #5

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: need new pump

    This is very frustrating, I could not get the pool pump to run all morning, but I waited a few hours and I got it going. It did trip the breaker a few times but I reset it and it held and now I have it running. When a pump goes bad,will it work intermittently or do they just quit and stop working. I need to know if I need to replace it or get it repaired. I am trying to avoid putting any money towards something that will die in a week or so.
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  6. Back To Top    #6
    Guest

    Re: need new pump

    Sounds like you may have a bad start capacitor. Those are pretty inexpensive to replace, if that is the culprit.

    Be careful if you try and do it yourself; capacitors like to hold a charge

  7. Back To Top    #7

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: need new pump

    Well it shut off again. I went in the basement to see if the breaker tripped, it did not so I got my digital voltmeter and I had 230 on the line side nothing on the load side if the time clock. I then bypassed the time clock and wired it straight through, and now it works. I guess the timer was bad. I have a disconnect switch mounted before the time clock so I will use that to turn on and off till I get a new timer.

    Hopefully that was the problem. I do have an issue of water squirting out once the pump is turned on for the first time in the morning but the pool store I go to charges $100 to replace the seal between the motor and the basket assembly.
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  8. Back To Top    #8
    Guest

    Re: need new pump

    Are you sure the leak is between the wet end and the motor? It could just be the O-Ring on the pump basket. I'd check that first, especially since that is a cheap fix!

  9. Back To Top    #9

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: need new pump

    I did replace the basket o-ring. The odd thing is I am getting air in the basket and water is seeping underneath the lid. I also have water leaking at the pvc connector coming out the top of the motor going to the filter.

    I did see water squirt out where the motor assembly and the pump basket, There was also a little corrosion at the same spot around one of the bolts.
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  10. Back To Top    #10
    Guest

    Re: need new pump

    Can you post a pic? Sounds like it might be a simple fix, but a picture would help!

  11. Back To Top    #11

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: need new pump

    /thanks for your reply. What's the best way to post pictures? I tried to upload a picture but it said that the file was too big.
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  12. Back To Top    #12
    Guest

    Re: need new pump

    Camera phone pics seem to post right up, but are usually a little "rough". I usually go to "Paint" and hit the size/skew control and reset to 50% on each (I make a copy that I can adjust so I have the original still). Haven't had a problem posting anything that size yet!

  13. Back To Top    #13

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: need new pump

    Here are some pictures. I hope the came out. Thanks.
    Attached Images Attached Images
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  14. Back To Top    #14
    Guest

    Re: need new pump

    It looks like you have threaded unions on both ends of the pump (very lucky ), so you should be able to "unthread" the pump and move it aside. Take the piece of pipe on the "out" side of the pump out of the pump and redo the pipe dope on the threads and put it back in and tighten it down snug. See if that stops the leak. Everything on the wet end and motor interface look to be leak free, from what I can see.

    It still looks to me like it is emanating from the lid/O-Ring to me though, unless you took the pic shortly after removing the lid and cleaning the basket. That's the only place that I see that looks like water has come from.

    How cool would that be if it was now all fixed and you didn't need a new pump for several more years?!

  15. Back To Top    #15

    Join Date
    May 2009
    Location
    Trenton NJ
    Posts
    497

    Re: need new pump

    It was the time clock that went bad, I been running the pump for 24 hrs. and i occasionally flip the switch on and off to make sure it starts up again. So I got a big break with that, hopefully I get a few more years.

    What is better to use pipe dope or teflon tape?

    As far as the lid goes, I am puzzled. The picture was taken before I removed the lid on the basket. The o-ring was replaced last year and I took it to the pool store and they told me it looks good and I have to agree. It was not cracked or flat, it looks brand new. I am puzzled as to why there is a leak around the lid.

    The one thing I do notice is the air bubbles seem to be coming from the inside perimeter of the lid, if that makes any sense. I will have the pool service guy take a look when I drop the pump off to replace the seal (gasket) on the pump.
    20,000 gallon viking fiberglass pool w/aqua comfort heat pump, pentair whisperflo pump 1.5hp autopilot dig-220 swg w/RC42 cell (42,000), pg2000 fiber optic lights
    hayward sand filter(medium is echoglass)
    Blue diamond robot cleaner

  16. Back To Top    #16
    Guest

    Re: need new pump

    Use dope on pipe that size. Teflon is good for smaller diameter pipe.

    You might have some grit or something in between the lid and pump pot. Maybe give them all a good once over to see that everything is clean.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •