Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pump noises

  1. Back To Top    #1

    Join Date
    Jul 2009
    Kingsville, TX

    Pump noises

    Greetings all,
    I posted a while back about some pump troubles. I managed to install the new pump motor without trouble; the fourth or fifth time I fit everything back together and it's worked a treat since. However, in the last few days, the pump has developed a bit of a clattering sound that goes away entirely if I apply downward force to the PVC pipe coming out of the top of the pump housing. Do you think it's a noise I ought to worry about, or attempt to fix? My pump sits on a concrete pad, if that matters. Thanks for your help.
    18/20x40 free form in ground 30,000 gal gunite sand filter, 1.5 hp pump with antique Polaris cleaner

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: Pump noises

    You might try putting a rubber pad underneath the pump. That will reduce vibration, which should reduce the noise.

    Also, check the impeller input (underneath the strainer basket), and make sure there isn't anything obstructing that area.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts